Bug 336361 - Cannon su to mockbuild
Cannon su to mockbuild
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-17 12:27 EDT by Orion Poplawski
Modified: 2013-01-09 20:42 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.8.4-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-29 15:05:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2007-10-17 12:27:40 EDT
Description of problem:

When running "mock shell" I can no longer "su - mockbuild", it asks for a
password.  This is helpful for testing munged builds.  If I run as root and then
do a no-clean build afterwards it often fails because it cannot remove the files
that root created.

Version-Release number of selected component (if applicable):
mock-0.7.6-1.fc8
Comment 1 Michael E Brown 2007-10-22 13:43:31 EDT
You can fix by removing the '!!' in /etc/passwd in the chroot.

I'm testing a fix for 0.8.3 
Comment 2 Michael E Brown 2007-10-22 14:32:45 EDT
fixed in upcoming 0.8.3
Comment 3 Fedora Update System 2007-10-24 03:06:17 EDT
mock-0.8.4-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mock'
Comment 4 Fedora Update System 2007-10-29 15:05:31 EDT
mock-0.8.4-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2007-11-06 11:12:02 EST
mock-0.8.4-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mock'
Comment 6 Fedora Update System 2007-11-08 01:01:40 EST
mock-0.8.4-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.