Bug 33672 - Crash recovery when rpm is not functioning
Crash recovery when rpm is not functioning
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-28 14:43 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-28 14:43:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-03-28 14:43:09 EST
RASH RECOVERY AND RPM

There seems to be subtle fault in the presentation of Red Hat that I wish 
to bring to your attention. 

I had enormous difficulty upgrading from rh 6.1 to 7.0, caused mainly by 
the change from  RPM 3 to 
RPM 4.   I could not get the rpm system to work because of circular 
dependencies in the database 
format.  In desperation I deleted RPM 3 and loaded RPM 4 off the CD.  To 
my horror, I found that I had 
no way of using RPM because it in rpm format, which of course need RPM to 
unpack it!   I resolved 
the problem by going to rpm.org and downloading RPM 4 in .tgz format, 
from which I could obtain a 
working version using gunzip and tar.

It struck me that a distribution ought to contain a rescue procedure that 
does not rely on having a 
working version of RPM available.  I suggest that RPM be provided not 
just as an RPM but also as a 
tar package, with tar available on the rescue disk or somewhere else 
convenient for unpacking.   This 
would allow a 'black start' with the need for a complete re-installation.
Comment 1 Jeff Johnson 2001-03-29 09:53:04 EST
All versions of rpm are always available at ftp.rpm.org, in packages that
can be unpacked with rpm2cpio, and, for the i386 platforms, in a tar
ball.

Whether a better job can be done with rescue disks and such is trickier,
as there simply isn't a whole lot of room on a floppy disk.

FWIW, if you had chosen to use the anaconda installer to upgrade
from 6.1 to 7.0, your upgrade path would have been far, far easier.

Otherwise, rpm-3.0.5 understands both version 3 and version 4 packages.

Circular dependencies, meanwhile, are a distribution problem, not an rpm
problem.
Yes there are/were big changes beween 6.1 and 7.0

Note You need to log in before you can comment on or make changes to this bug.