Bug 33679 - Missing parts in SPEC file to build mysql module for php3
Missing parts in SPEC file to build mysql module for php3
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-28 15:41 EST by Russell McOrmond
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-07 18:59:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell McOrmond 2001-03-28 15:41:28 EST
Looking at the SPEC file for php-3.0.18-1.6.x it suggests that all I need
to do to build a mysql PHP module is to change the define at the top.  This
is not the case as there is other missing information to be able to build
the mysql module.

Here is the missing info as a patch file:

--- php.spec    Fri Jan 19 11:01:28 2001
+++ php.spec-rwm        Tue Mar 27 22:31:49 2001
@@ -48,6 +48,21 @@
 The php-manual package provides comprehensive documentation for the
 PHP3 HTML-embedded scripting language, in HTML format.
 
+# MySQL module
+%if %{mysql}
+%package mysql
+Obsoletes: mod_php3-mysql
+Group: System Environment/Daemons
+Summary: A MySQL database module for PHP3
+Prereq: php = %{version}
+
+%description mysql
+The php-mysql package includes a dynamic shared object (DSO) that can
+be compiled in to the Apache Web server to add mysql database
+support to PHP3.
+%endif
+
+
 %package pgsql
 Group: System Environment/Daemons
 Prereq: php = %{version}
@@ -114,6 +129,8 @@
        --with-system-regex \
        --disable-debug \
        --with-zlib \
+       --with-dbase \
+       --with-filepro \
        --with-gdbm \
        --with-db2 \
        --enable-debugger \
@@ -121,7 +138,6 @@
        --enable-track-vars \
        --enable-sysvsem \
        --enable-sysvshm \
-       --enable-track-vars \
        --with-xml \
        --with-ftp
 


Note: While not a bug, I also note that --enable-track-vars was included
twice in the configure line.
Comment 1 Bill Nottingham 2001-12-07 22:37:23 EST
This is not something that would be backported to a future 6.x package, most likely.

Note You need to log in before you can comment on or make changes to this bug.