Bug 337061 - tunepimp: Cannot decode file. (Decoder crashed)
tunepimp: Cannot decode file. (Decoder crashed)
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libtunepimp (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-18 00:37 EDT by Sean Bruno
Modified: 2008-03-02 08:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-02 08:45:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is an MP3 file that crashes libmusicbrainz on my machine (3.65 MB, audio/mpeg)
2007-10-18 00:37 EDT, Sean Bruno
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 158434 None None None Never

  None (edit)
Description Sean Bruno 2007-10-18 00:37:32 EDT
Description of problem:
Amarok is failing to tag files via libmusicbrainz.  More specifically it is
reporting a crash of the musicbrainz backend.

Version-Release number of selected component (if applicable):
[sean@home-desk ~]$ rpm -q -a|grep musicbrainz
libmusicbrainz-2.1.4-1.fc7
libmusicbrainz-2.1.4-1.fc7
[sean@home-desk ~]$ rpm -q -a|grep amarok
amarok-extras-nonfree-1.4.4-1.lvn7
amarok-1.4.7-5.fc7
amarok-1.4.7-5.fc7
amarok-visualisation-1.4.7-5.fc7


How reproducible:
Seems to happen every time.

Steps to Reproduce:
1. Attempt to tag a file with libmusicbrainz
  
Actual results:
Crash dialog:
Tunepimp (MusicBrainz tagging library) returned the following
error: "Cannot decode file. (Decoder crashed)".

Once it crashes, you cannot tag that file with libmusicbrainz again until you
restart Amarok.  You can however, tag other files.

Expected results:
It tags the file if the data is found at musicbrainz.org

Additional info:
Comment 1 Sean Bruno 2007-10-18 00:37:32 EDT
Created attachment 230651 [details]
This is an MP3 file that crashes libmusicbrainz on my machine
Comment 2 Rex Dieter 2008-02-25 07:44:30 EST
$ rpm -q amarok libtunepimp libtunepimp-extras-nonfree
please.
Comment 3 Rex Dieter 2008-02-25 07:50:16 EST
Fwiw, I just tried importing the provided, mp3, and I can edit tags as well as
"Fill in tags using MusicBrainz".
Comment 4 Sean Bruno 2008-02-25 10:52:12 EST
The same issue affects my F8 installations:

[sean@home-desk ~]$ rpm -q amarok libtunepimp libtunepimp-extras-nonfree
amarok-1.4.8-1.fc8
libtunepimp-0.5.3-9.fc8
libtunepimp-extras-nonfree-0.5.3-4.lvn8


Tagging will fail after some amount of editing.  This amount is not fixed and
changes.  I can't seem to edit more than 20 files before I run into this issue.
Comment 5 Rex Dieter 2008-02-25 11:01:51 EST
Can you try updating this:
https://admin.fedoraproject.org/updates/F8/pending/taglib-1.5-1.fc8
Comment 6 Sean Bruno 2008-02-25 11:21:32 EST
That didn't help with the crash. 

I selected 8 untagged MP3's.  I then selected the Fill-in tags using Musicbrainz
button.  After a few moments, the crash dialog appears.
Comment 7 Rex Dieter 2008-02-25 11:32:36 EST
OK, I can confirm now (appears to be x86_64 specific?).  
Would appear that libtunepimp/libmusicbrainz support is just (a bit, at least) 
flaky.
Comment 8 Fedora Update System 2008-02-25 19:25:24 EST
taglib-1.5-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update taglib'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-1960
Comment 9 Sean Bruno 2008-02-25 20:13:10 EST
I installed the update referenced in comment #8 when it was suggested in Comment
#5.  No change to behavior noted and the same error persists.
Comment 10 Rex Dieter 2008-02-25 20:17:38 EST
Sean, looks like we've tried most everything we can do here packaging-wise, it
would be a good idea at this point to escalate the issue to amarok's developers
by reporting this upstream to bugs.kde.org.
Comment 11 Sean Bruno 2008-02-25 23:41:32 EST
As per request, I have filed this upstream with the kde folks:

https://bugs.kde.org/show_bug.cgi?id=158434
Comment 12 Sean Bruno 2008-02-26 00:07:28 EST
Just for the record, a libtunepimp update appeared
today(libtunepimp-0.5.3-11.fc8).  This had no effect on behavior after I
restarted Amarok.
Comment 13 Rex Dieter 2008-03-02 08:45:29 EST
We'll continue to track this upstream, thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.