This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 33738 - rpc.rquotad in Wolverine is wrong version
rpc.rquotad in Wolverine is wrong version
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
David Lawrence
http://sourceforge.net/projects/linux...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-28 23:36 EST by Nathan Scott
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-30 23:09:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan Scott 2001-03-28 23:36:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76C-SGI [en] (X11; I; IRIX 6.5 IP32)


hi,

From a look in the source rpm from Wolverine for nfs-utils-0.3.1, in the
file utils/rquotad/README.okir, it is evident that the version of
rpc.rquotad which this code builds will not work with the Wolverine kernel
version of quota (i.e. the 2.4.X-acX version of the kernel, which contains
Jan Kara's rewrite of Linux quota).

There is now a new version (3.01) of the quota tools at:
	http://sourceforge.net/projects/linuxquota/
and also at:
	ftp://atrey.karlin.mff.cuni.cz/pub/local/jack/quota/utils/
that will work for either kernel version of quota, and also for XFS quota. 
The version of rpc.rquotad there will work for either kernel version and
also for XFS filesystems.

cheers.

Reproducible: Always
Steps to Reproduce:
1. Run quota(8) on a box with a NFS mounted file system, where the NFS
filesystem is mounted from a machine running Wolverine, and with quota
enabled on that filesystem;
2. The rpc.rquotad on the server machine will interact badly with the
Wolverine version of the kernel + quota, and no result RPC will be sent
back to quota(8) and the NFS mount will be ignored by quota(8).
Comment 1 Glen Foster 2001-03-29 16:21:49 EST
We (Red Hat) really need to try to fix this before next release.
Comment 2 Preston Brown 2001-03-30 23:09:10 EST
I'm on it.
Comment 3 Preston Brown 2001-03-30 23:51:33 EST
Nathan:  we will stay at quota 3.00 for release, but include the rquotad that 
it includes.  We will not move to 3.01 yet for the reasons I outlined in a 
mail I just sent you and the other quota developers.

Note You need to log in before you can comment on or make changes to this bug.