Bug 337411 - anaconda does not recognize package selection in kickstart file
Summary: anaconda does not recognize package selection in kickstart file
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: comps   
(Show other bugs)
Version: 8
Hardware: i586
OS: Linux
low
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Jeremy Katz
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-18 08:55 UTC by Michael Jørgensen
Modified: 2014-03-17 03:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 22:35:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart file (1.29 KB, text/plain)
2007-10-18 08:55 UTC, Michael Jørgensen
no flags Details
anaconda.log (33.62 KB, text/plain)
2007-10-18 21:39 UTC, Michael Jørgensen
no flags Details
anaconda.syslog (21.59 KB, text/plain)
2007-10-18 21:39 UTC, Michael Jørgensen
no flags Details

Description Michael Jørgensen 2007-10-18 08:55:41 UTC
Description of problem:
I'm installing using a kickstart file, but there are a number of unexpected 
problems.
1) During installation, anaconda shows a dialog box stating that the package 
name samba-swat is unknown. I instruct anaconda to just ignore this package.
2) After installation a large number of gnome related packages are installed, 
even though I did not request that in the kickstart file.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
After installation, I'm able to manually install samba-swat, using the command:
yum install samba-swat

After installation, the following gnome-related packages are installed:
[root@mij-6 mij]# rpm -q -a | grep gnome
gnome-mime-data-2.18.0-2.fc7
libgnomecanvas-2.20.0-1.fc8
gnome-python2-2.20.0-1.fc8
gnome-keyring-2.20-1.fc8
nodoka-theme-gnome-0.3.2-1.fc8.1
libgnome-2.20.0-2.fc8
libgnomeui-2.20.0-1.fc8
gnome-mount-0.7-0.git20070725.1.fc8
gnome-python2-gconf-2.20.0-1.fc8
gnome-python2-gnomevfs-2.20.0-1.fc8
gnome-themes-2.20.0-1.fc8
bluez-gnome-0.14-5.fc8
gnome-vfs2-2.20.0-1.fc8
PolicyKit-gnome-0.6-0.git20070925.fc8
gnome-python2-canvas-2.20.0-1.fc8
gnome-python2-bonobo-2.20.0-1.fc8


Expected results:
Since the package name in the kickstart file is correct, I expect anaconda to 
install it without complaints.

Since I'm running Fedora as a headless server, I do not expect packages like 
nodoka-theme-gnome and gnome-themes etc. to be installed.

Additional info:
My kickstart file is attached.

Comment 1 Michael Jørgensen 2007-10-18 08:55:41 UTC
Created attachment 230811 [details]
kickstart file

Comment 2 Chris Lumens 2007-10-18 19:29:13 UTC
(1) Please attach /var/log/anaconda* to this bug report so we can see what might
be going on regarding samba-swat.

(2) I'm pretty sure you are getting all those gnome-related packages because you
asked to install the admin-tools group which includes many of the
system-config-* packages, some of which have very complex library requirements.
 Most of the packages you listed are just providing libraries.  The remainder
are being pulled in as requirements of the first set.

Comment 3 Michael Jørgensen 2007-10-18 21:39:24 UTC
Created attachment 231631 [details]
anaconda.log

Comment 4 Michael Jørgensen 2007-10-18 21:39:54 UTC
Created attachment 231641 [details]
anaconda.syslog

Comment 5 Michael Jørgensen 2007-10-18 21:42:59 UTC
I've added the requested attachments.


Comment 6 Chris Lumens 2007-10-22 17:56:19 UTC
Not only is samba-swat not found, but system-config-securitylevel-tui isn't
either.  Do these packages exist on your hard drive installation media?

Comment 7 Michael Jørgensen 2007-10-23 07:35:57 UTC
Geez, I just checked, and the packages you mention are not there. I'm using
Fedora-7.92-i386-DVD.iso as my hard drive installation media.

So, I guess this is not a bug, unless those packages were meant to be present in
the iso file.

And I've removed the admin-tools group from the package selection in the
kickstart file, and that eliminates a bunch of the gnome packages. The remaining
ones are dependencies caused by the BlueTooth package bluez-utils. Once that
package is removed (I don't need bluetooth support), a lot of supporting
packages can be deleted:

[root@mij-6 mnt]# rpm -e bluez-utils
[root@mij-6 mnt]# rpm -e gnome-vfs2 gnome-mount libgnome NetworkManager-openvpn
NetworkManager-vpnc PolicyKit-gnome libbonoboui libgnomeui gnome-vfs2-obexftp
bluez-gnome

It would be nice, if the bluez-utils package did not pull in all these gnome
libraries, or alternatively, was not included by default in the "Base" group.


Comment 8 Chris Lumens 2008-04-07 15:08:54 UTC
Your comment about bluez-utils is a comps problem, as it does all the grouping.

Comment 9 Bill Nottingham 2008-04-07 16:00:14 UTC
I'm not seeing where bluez-utils requires parts of the GNOME stack.


Note You need to log in before you can comment on or make changes to this bug.