Bug 337591 - [5.2]The information of weight/cap is a unusable parameter for starting a guest domain.
[5.2]The information of weight/cap is a unusable parameter for starting a gue...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
5.1
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-18 05:40 EDT by Tatsuro Enokura
Modified: 2009-12-14 16:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-27 09:20:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tatsuro Enokura 2007-10-18 05:40:22 EDT
Description of problem:
  I set the information of weight/cap to configuration file, and execute 
  "virsh start" with that file.
  But the information of weight/cap is lost.
  
  The information of weight/cap is a unusable parameter for starting a guest
  domain.

Version-Release number of selected component (if applicable):
   installed from RPM (RHEL5.1 RC):
       kernel-xen: 2.6.18-52.el5
       xen: 3.0.3-41.el5
   got from cvs:
       libvirt: upstream(Revision of Changelog is 1.772)
   
How reproducible:
  Always

Steps to Reproduce:
1. Start the guest domain with the configuration file
  # cat /etc/xen/guest_dom
  name = "guest_dom"
  uuid = "29610f8f-e164-ea5a-a54a-2d909e8d9043"
  maxmem = 1024
  memory = 1024
  vcpus = 4
  cpu_weight = 512
  cpu_cap = 300
  bootloader = "/usr/bin/pygrub"
  on_poweroff = "destroy"
  on_reboot = "restart"
  on_crash = "restart"
  vnc = 1
  vncunused = 0
  vncdisplay = "25"
  disk = [ "phy:/dev/sda5,xvda,w" ]
  vif = [ "mac=02:17:42:2F:01:13,bridge=xenbr2" ]  

  # virsh start guest_dom
  
2. Confirm the information of weight/cap
  # virsh schedinfo guest_dom
  Scheduler:      credit
  weight         : 256
  cap            : 0

Actual results:
  The information of weight/cap that described at configuration file is lost
when starting a guest domain with "virsh start".

Expected results:
  The information of weight/cap that described at configuration file is usable
for starting a guest domain.
  
Additional info:
Comment 1 RHEL Product and Program Management 2007-10-19 11:55:21 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Daniel Veillard 2007-10-19 12:01:46 EDT
This hasn't been discussed upstream, this is a feature request for libvirt
and won't be accepted in U2 if this hasn't been accepted upstream first
and integrated in a public libvirt release.

Daniel
Comment 3 RHEL Product and Program Management 2008-03-11 15:39:17 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 4 Daniel Veillard 2008-05-23 07:38:29 EDT
This could be added to Update 3 if the upstream patch is clearly identified

Daniel
Comment 6 Daniel Veillard 2008-05-27 09:20:45 EDT
Actually this was discussed upstream and we decided to not do it,
at least not in the suggested form and the thread upstream ended up at
https://www.redhat.com/archives/libvir-list/2008-January/msg00076.html

Based on this I think the most correct is to resolve as WONTFIX, because
that seems the outcome of the upstream discussions,

Daniel


Note You need to log in before you can comment on or make changes to this bug.