Bug 337711 - addrtype match support is missing in iptables binaries
addrtype match support is missing in iptables binaries
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: iptables (Show other bugs)
4.5
All Linux
low Severity medium
: ---
: ---
Assigned To: iptables-maint-list
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-18 06:55 EDT by Simon Matter
Modified: 2009-08-22 09:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-26 11:02:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix binary builds of iptables (652 bytes, application/x-gzip)
2007-10-18 06:55 EDT, Simon Matter
no flags Details

  None (edit)
Description Simon Matter 2007-10-18 06:55:06 EDT
Description of problem:
addrtype match support is missing in iptables binaries

Version-Release number of selected component (if applicable):
iptables-1.2.11-3.1.RHEL4

How reproducible:


Steps to Reproduce:
1. Try to use addrtype match with iptables
2.
3.
  
Actual results:
addrtype match support is missing

Expected results:
addrtype match support should work

Additional info:
The lib /lib/iptables/libipt_addrtype.so is missing in the binary build. Looks
like the build system was broken because simply rebuilding from src.rpm builds
fine. Adding glibc-kernheaders as buildreq seems to make things more safe to
build correctly.
Comment 1 Simon Matter 2007-10-18 06:55:06 EDT
Created attachment 230941 [details]
Patch to fix binary builds of iptables
Comment 3 RHEL Product and Program Management 2008-08-26 11:02:10 EDT
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request.
Comment 4 Simon Matter 2009-08-22 09:31:43 EDT
This bug is fixed now in 4.8 because the package has been rebuilt on a proper buildsystem.

Note You need to log in before you can comment on or make changes to this bug.