Bug 337751 - vym 1.10.0 is out
vym 1.10.0 is out
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vym (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
http://www.insilmaril.de/vym/#id2247312
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-18 07:52 EDT by Till Maas
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-25 08:31:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2007-10-18 07:52:19 EDT
A newer version of vym than currently in Fedora is out. It contains a lot of
bugfixes and some new features. Would you maybe ask for branching vym in cvs for
F-8 and update the spec for devel (F-9)?
Comment 1 Jon Ciesla 2007-10-18 08:05:19 EDT
Hmm, won't build for me on F-7:
uic: File generated with too recent version of Qt Designer (4.0 vs. 3.3.8)

When will we get qt4?  F9?
Comment 2 Till Maas 2007-10-18 08:15:02 EDT
qt4 is in qt4(-devel) and already in F-7, so the BR need to be adjusted.
Comment 3 Jon Ciesla 2007-10-18 08:30:39 EDT
Thanks, I'll try that.  I suppose searching koji with qt* instead of just qt
would have helped. :)
Comment 4 Till Maas 2007-10-18 08:32:40 EDT
btw. you need to use qmake-qt4 instead of qmake in the spec.
Comment 5 Till Maas 2007-10-18 08:38:49 EDT
I did a first build for F7 with all patches disabled and with qmake-qt4 instead
of qmake and it worked. I also removed kdelib from BR, so maybe it is not needed
(anymore). But I spotted a problem, $RPM_OPT_FLAGS is not used to build the
package, which maybe was also a problem for the older release, this should be
changed.
Comment 6 Jon Ciesla 2007-10-18 10:04:24 EDT
I've got it all ready except for the $RPM_OPT_FLAGS issue.  I've tried it at the
qmake and make steps, and both break.  Any suggestions?
Comment 7 Jon Ciesla 2007-10-18 10:36:48 EDT
Mock rebuild confirms no need for explicit BR for kdelibs.  Odd.  Took it out.
Comment 8 Till Maas 2007-10-18 11:59:26 EDT
(In reply to comment #6)
> I've got it all ready except for the $RPM_OPT_FLAGS issue.  I've tried it at the
> qmake and make steps, and both break.  Any suggestions?

What did you do? Here 
qmake-qt4 INSTALLDIR=%{buildroot}%{_prefix} \
QMAKE_CFLAGS="%{optflags}" \
QMAKE_CXXFLAGS="%{optflags}" \
QMAKE_LFLAGS="%{optflags}"
seems to work, but I did not yet test whether it compiles completely. The the
%{optflags} are honoured, though.
Comment 9 Jon Ciesla 2007-10-18 12:49:49 EDT
I just stuck $RPM_OPT_FLAGS after make and qmake, respectively.

This works great, builds, and tests out OK.  I'll wait a bit to see what the
list brings, then import and build.

Thanks.
Comment 10 Till Maas 2007-10-18 18:48:31 EDT
Btw.

%find_lang %{name} || touch %{name}.lang
-f %{name}.lang

does not work in your spec, because find_lang does not know about the way vym
handles its translations.

Btw. I cc'ed you in an e-mail with some patches that should make your
maitainance of vym in Fedora a lot easier, especially when they are accepted
upstream. One of them allows you to use

DOCDIR="%{_docdir}/%{name}-%{version}" PREFIX=%{_prefix} after qmake-qt4, which
is essentially, what you did with the {name}-pro.patch patch but not with
hardcoded values. And another also adds DOCDIR to the searchList for the pdf,
like the %{name}-mainwindow.patch patch does in a hardcoded way. And the last
patch makes vym use xdg-open instead of konqueror/acroread to open URLs and
PDFs. Btw. imho the make invocation should be
%{__make} install INSTALL_ROOT=%{buildroot} COPY="%{__cp} -p -f"
because afair DESTDIR is ignored with the makefile, but INSTALL_ROOT is the
variable which does what DESTDIR does for packages that use autotools.
Comment 11 Jon Ciesla 2007-10-25 08:31:59 EDT
All changes applied and built for rawhide.  Will built for other releases after
F-8 GA.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.