This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 337981 - VFS: Busy inodes after unmount following NFS problems
VFS: Busy inodes after unmount following NFS problems
Status: CLOSED DUPLICATE of bug 253663
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
x86_64 Linux
urgent Severity high
: rc
: ---
Assigned To: Steve Dickson
Martin Jenner
GSSApproved
: ZStream
Depends On:
Blocks: 424251
  Show dependency treegraph
 
Reported: 2007-10-18 10:06 EDT by Bob Gautier
Modified: 2008-01-24 15:51 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-24 15:51:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bob Gautier 2007-10-18 10:06:42 EDT
Description of problem:

Following some trouble with remote NFS (v3) file systems, the machine crashed
having logged the following message:

VFS: Busy inodes after unmount of 0:1f. Self-destruct in 5 seconds.  Have a nice
day...

Version-Release number of selected component (if applicable):

kernel 2.6.18-8.el5

How reproducible:

This was a single crash, probably provoked by very special circumstances

Steps that led to the crash:

User tries to access a stale NFS mount:

    cd /path1

The user tried to clear the stale mount by unmounting:

    umount /path1

This failed with 'device is busy'.  Locating the processes that were keeping the
stale mount busy, the user tried to kill them, eventually resorting to

    kill -9 pid...

The processes went away and

    umount /path1

succeeeded.  The filesystem was then remounted:

    mount server:/path/to/files /path1

The original job could then be performed, and the file system unmounted:

    cd /path1
    # do stuff...
    umount /path1

Another NFS filesystem was then mounted:

    mount server:/path/to/more/files /path2

Files were written to the /path2 tree without error

Finally, the user did:

    cd /path2/OS/
    createrepo ... 

At this point, the machine crashed.  We don't know when the 'have a nice day'
message was logged relative to the crash.
Comment 6 RHEL Product and Program Management 2007-11-21 13:46:00 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 14 Don Zickus 2008-01-24 15:51:17 EST

*** This bug has been marked as a duplicate of 253663 ***

Note You need to log in before you can comment on or make changes to this bug.