Bug 338111 - Installing software from Steam fails with white/blank screen
Installing software from Steam fails with white/blank screen
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-18 11:38 EDT by Douglas E. Warner
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-21 16:13:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Douglas E. Warner 2007-10-18 11:38:08 EDT
Description of problem:
Inside Steam (Steam itself runs fine once tahoma.ttf is installed) I am unable 
to install games.  When clicking on "Install" for a game (HalfLife 2 Demo, in 
this case - others were tried as well) the "browser window" (I believe Steam 
uses the gecko renderer from wine's iexplore) turns white and nothing happens.

In contrast, when I compile stock wine 0.9.47 and attempt the same thing, a 
window prompting me to install the game as normal pops up.

This problem occurred for me for both 0.9.46 and 0.9.47 (from koji for F7).


Version-Release number of selected component (if applicable):
wine-core-0.9.47-1.fc7
wine-tools-0.9.47-1.fc7

How reproducible:
Every time


Steps to Reproduce:
1. Run Steam
2. Select "Store" tab
3. Select "Demos"
4. Select "Halflife 2 Demo"
5. Click "Install" button
  
Actual results:
Screen turns white (blank?) and install does not proceed.

Expected results:
Install window pops up and install and download proceeds as normal.
Comment 1 Andreas Bierfert 2007-10-20 05:48:40 EDT
That is really strange. Could you please try to install the meta package wine
and try again.
Comment 2 Douglas E. Warner 2007-10-20 21:57:09 EDT
Installing the meta package seemed to work and pulled in these dependencies:
wine-ldap - 0.9.47-1.fc8.i386
wine-nas - 0.9.47-1.fc8.i386
wine-cms - 0.9.47-1.fc8.i386
wine-esd - 0.9.47-1.fc8.i386
wine-twain - 0.9.47-1.fc8.i386
wine-capi - 0.9.47-1.fc8.i386
wine-jack - 0.9.47-1.fc8.i386
Comment 3 Andreas Bierfert 2007-10-21 06:00:00 EDT
So with this installed steam works?
Comment 4 Douglas E. Warner 2007-10-21 13:02:52 EDT
(In reply to comment #3)
> So with this installed steam works?

Correct - I can install games from within Steam now. Apparently Steam must 
require one of the other libs (cms would be my guess, but I haven't tested 
yet - most of the others are just audio libraries).
Comment 5 Andreas Bierfert 2007-10-21 16:13:05 EDT
That would have been my guess as well. I will close this as NOTABUG because for
everyday use it is recommended to have the wine meta package installed (as
discussed with wine upstream). If you have time to figure out if it really is
wine-cms please let me know.
Comment 6 Douglas E. Warner 2007-10-22 10:10:56 EDT
I removed each of the additional wine-* packages one-by-one until I was just 
left with wine-core and wine-tools but everything still worked.  I suspect 
my .wine directory was modified when I ran Steam with the appropriate package 
installed so that it now works properly without the package installed.

Unfortunately I don't have the time to nuke my .wine directory and install 
Steam and test execution for each wine subpackage, so I'll just let this bug 
closed as NOTABUG and use the wine meta-package from now on.

Note You need to log in before you can comment on or make changes to this bug.