Bug 338231 - PPC function breakpoint too far behind the prologue
PPC function breakpoint too far behind the prologue
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gdb (Show other bugs)
4.0
powerpc Linux
medium Severity medium
: rc
: ---
Assigned To: Jan Kratochvil
: Regression
Depends On: 140532
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-18 12:06 EDT by Jan Kratochvil
Modified: 2008-07-24 15:56 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0717
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:56:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Jan Kratochvil 2007-10-30 11:53:43 EDT
Patches were now prepared for no regression since RHEL-4.5:

2007-03-13  Daniel Jacobowitz  <dan@codesourcery.com>

       * rs6000-tdep.c (rs6000_skip_prologue): Use skip_prologue_using_sal.
       (rs6000_in_function_epilogue_p): Use extract_unsigned_integer.
       (refine_prologue_limit): Delete.
       (skip_prologue): Don't call it.  Use extract_unsigned_integer.
       Assume lim_pc is set.  Correct check for incomplete prologues.
       Do not skip clobbers of the frame pointer.

[ Backported for GDB-6.3. ]

2006-05-11  Fred Fish  <fnf@specifix.com>

       * symtab.c (skip_prologue_using_sal): Handle single line functions
       like "foo(){}", which may optimize down to a single return inst.

2007-03-13  Daniel Jacobowitz  <dan@codesourcery.com>

       * symtab.c (skip_prologue_using_sal): Fail if there is only one
       sal. 

2007-04-17  Andreas Schwab  <schwab@suse.de>

       * symtab.c (skip_prologue_using_sal): Allow the end of the prologue
       sal to be bigger than the end of the function.

2007-10-30  Jan Kratochvil  <jan.kratochvil@redhat.com>

       * symtab.c (skip_prologue_using_sal): Restrict the changes only to PPC
       for RHEL-4.6 Bug 140532.
Comment 2 Andrew Cagney 2007-12-04 15:29:27 EST
dev-ack+

fix and test result improvement available.

IBM requested unwind enhancements caused minor regression in prologue code; fixing.
Comment 3 RHEL Product and Program Management 2007-12-04 15:35:08 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 RHEL Product and Program Management 2007-12-04 15:36:13 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 11 errata-xmlrpc 2008-07-24 15:56:34 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0717.html

Note You need to log in before you can comment on or make changes to this bug.