Bug 338461 - Shouldn't show wmaster0 in net device list
Shouldn't show wmaster0 in net device list
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-18 13:31 EDT by Dan Williams
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 11:36:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Williams 2007-10-18 13:31:18 EDT
wmaster isn't actually a usable network device; it's the master device for
things like sniffers and such.  Only actual 802.11 STA devices (ie, wlanX or
ethX) should be shown because those are the ones that can actually be configured.

You can distinguish between the two by checking the 'type' field of each
device's sysfs directory (ie /sys/class/net/wlan0/type).  A type '1' is usable,
but whatever type wmasterX uses is not.  I'd recommend just excluding whatever
type wmasterX is rather than only letting type 1 through.
Comment 1 Bill Nottingham 2007-10-18 15:23:57 EDT
It shows irda too, actually.
Comment 2 Chris Lumens 2007-10-19 11:36:06 EDT
This should be fixed in the next build of anaconda.

Note You need to log in before you can comment on or make changes to this bug.