Bug 338531 - Xorg fails to start on Intel G33
Xorg fails to start on Intel G33
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Depends On:
  Show dependency treegraph
Reported: 2007-10-18 14:18 EDT by John W. Lockhart
Modified: 2009-01-09 02:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-01-09 02:19:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Intel G33 log, F8T3-i686-KDE LiveCD (40.81 KB, text/plain)
2007-10-18 14:18 EDT, John W. Lockhart
no flags Details
Log when started with BIOS 1MB-VideoRAM setting (44.62 KB, patch)
2007-10-19 04:52 EDT, John W. Lockhart
no flags Details | Diff

  None (edit)
Description John W. Lockhart 2007-10-18 14:18:56 EDT
Description of problem:
Xorg fails to start on Intel G33.  Logfile attached.

Version-Release number of selected component (if applicable):

Log is from the F8T3 LiveCD, i686-KDE flavor, on a Core2Duo E6850
system, Gigabyte motherboard, booting off a SATA DVD-RW.

Also tried the x86_64 installation disk, and it failed to start X,
as well; but I didn't catch the log there.
Comment 1 John W. Lockhart 2007-10-18 14:18:56 EDT
Created attachment 231361 [details]
Intel G33 log, F8T3-i686-KDE LiveCD
Comment 2 John W. Lockhart 2007-10-19 04:51:04 EDT
The first attempt was made with a BIOS setting of using 8MB for video RAM, plus
"1~2 GTT".  rhgb came up okay from the livecd, but not the X server.

I have now tried it with a 1MB setting for video RAM -- rhgb came up in much
lower resolution/depth, and X started -- but not useably.  Approximately 2 lines
of a Konsole on the display were viewable -- everything else was a nightmare of
misdrawn rectangles, video artifacts, and dancing vertical stripes.

"it" is the F8T3 i686-KDE LiveCD again.

Those are the only 2 settings in this particular BIOS.

I'll attach the X Log from this attempt in case the contrast is at all useful.
Comment 3 John W. Lockhart 2007-10-19 04:52:56 EDT
Created attachment 232361 [details]
Log when started with BIOS 1MB-VideoRAM setting
Comment 4 Dave Airlie 2007-10-20 15:45:07 EDT
hmm if rhgb comes up okay I can't see why X wouldn't .. maybe you could disable
rhgb and see if X starts.. 

the 1MB is a known issue so please try with the 8MB..
Comment 5 John W. Lockhart 2007-10-21 05:36:34 EDT
I'll give that a try.

The hardware is a Gigabyte GA-G33M-DS2R motherboard with BIOS rev F4.  There are
2 subsequent BIOS revisions, neither of which claims to address any graphics
issues (but which take away at least one feature found in F4).  I won't be
messing with the BIOS unless/until I find a way to restore this revision, which
for some reason isn't on the manufacturer's site any more -- just in case other
revisions don't work as well.
Comment 6 Matěj Cepl 2007-10-22 15:14:35 EDT
Setting to NEEDINFO just so that we don't forget there is something to expect
from you.
Comment 7 John W. Lockhart 2007-10-25 14:49:12 EDT
Re comment 5 and 6 -- I've tried removing the "rhgb quiet" from the boot lines
of the i386 KDE-Live CD.  No change, still fails the same way in the log.

Also tried with the regular x86_64 LiveCD (burned to a DVD), with and without
rhgb in the boot command.  Still fails the same way.

Not sure what to try next.
Comment 8 John W. Lockhart 2007-10-25 14:50:12 EDT
Er, I meant the F8T3 i686 KDE LiveCD in comment 7, the same one I started out with.
Comment 9 chris.gow 2007-12-28 01:02:56 EST
I have a similar problem on my computer although I was able to install fedora 
8. When I need to reboot to complete the installation, that's when X fails 
with the same error as the original poster. My hardware is:
Intel Quad Core Q6600
Gigabyte GA-G33M-S2H

Judging from some searches, it looks like this is a pretty common situation 
for this video chipset. The driver looks for a /dev/agpgart device which 
appears to not exist for motherboards that don't have apg ports (makes sense)
Comment 10 Bug Zapper 2008-11-26 03:00:18 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 11 Bug Zapper 2009-01-09 02:19:31 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.