Bug 338671 - mod_nss does not work with mod_proxy
mod_nss does not work with mod_proxy
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mod_nss (Show other bugs)
7
All Linux
medium Severity high
: ---
: ---
Assigned To: Rob Crittenden
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-18 15:41 EDT by Rob Crittenden
Modified: 2008-01-24 16:52 EST (History)
0 users

See Also:
Fixed In Version: 1.0.7-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 03:03:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Register the mod_ssl functions if not loaded (3.77 KB, patch)
2007-10-18 15:46 EDT, Rob Crittenden
no flags Details | Diff

  None (edit)
Description Rob Crittenden 2007-10-18 15:41:47 EDT
Description of problem:

It is not possible to use mod_nss with mod_proxy, even when proxying to an
unsecured host.

The reason is that mod_proxy uses some functions provided by mod_ssl to identify
the protocol, enable or disable the SSL engine and to retrieve SSL variables.

Version-Release number of selected component (if applicable):

mod_nss-1.0.7-1.fc7

How reproducible:

Every time

Steps to Reproduce:
1. Setup Apache with mod_nss
2. Add a ProxyPass and ProxyPassReverse
3. Hit the server
  
Actual results:

You'll get an error about an SSL write failure in the log and a 500 in the browser.

Expected results:

The page to be displayed
Comment 1 Rob Crittenden 2007-10-18 15:46:14 EDT
Created attachment 231461 [details]
Register the mod_ssl functions if not loaded

If mod_nss is not loaded then mod_nss will register the functions needed by
mod_proxy.
Comment 2 Rob Crittenden 2007-10-18 15:47:19 EDT
Committed upstream and checked into FC-6, F-7 and devel trees.
Comment 3 Fedora Update System 2007-10-24 03:03:45 EDT
mod_nss-1.0.7-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Fedora Update System 2008-01-24 16:52:17 EST
mod_nss-1.0.7-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.