Bug 338701 - [thinice] OO.o crashes a lot in SalGraphics::GetNativeControlRegion
[thinice] OO.o crashes a lot in SalGraphics::GetNativeControlRegion
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: Reopened
: 245651 299681 333271 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-18 15:45 EDT by Ronald
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.3.0-6.4.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-01 17:20:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of the backtraces. (33.12 KB, text/plain)
2007-10-18 15:45 EDT, Ronald
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 82608 None None None Never

  None (edit)
Description Ronald 2007-10-18 15:45:51 EDT
Description of problem:

OOO Suite crashes when performing certain tasks. Or when under heavy load. Or
after long use.

Version-Release number of selected component (if applicable):

It probably affets the entire suite so I give you all the versions:

rpm -aq | grep openoffice
openoffice.org-calc-2.3.0-6.3.fc8
openoffice.org-impress-2.3.0-6.3.fc8
openoffice.org-graphicfilter-2.3.0-6.3.fc8
openoffice.org-langpack-nl-2.3.0-6.3.fc8
openoffice.org-draw-2.3.0-6.3.fc8
openoffice.org-core-2.3.0-6.3.fc8
openoffice.org-writer-2.3.0-6.3.fc8

How reproducible:

Many ways to make it crash. For example:

- Insert a diagram
- Open some sections in the options screen
- Inserting some pictures (rare)

Steps to Reproduce:
1. Install Fedora Core 7.92 (fully updated)
2. Start Openoffice
3. Perform one of the ways to make it crash (as listed above)
  
Actual results:

According to OO it's a crash. I'm getting backtraces (see the attachment)

Expected results:

That it just perfoms the tasks I request it to do. Without backtraces :)

Additional info:

If you need additional info, feel free to ask :)
Comment 1 Ronald 2007-10-18 15:45:51 EDT
Created attachment 231451 [details]
Output of the backtraces.
Comment 2 Caolan McNamara 2007-10-19 03:17:56 EDT
There has been one or two reports, but the previous reports were on nvidia
drivers, and so I jumped to the conclusion that it was the 3rd party binary
drivers, in this case the driver is vesa.

Your desktop is "not GNOME", what env are you running OOo in, KDE ? something
else. And what theme are you using, my working theory is that some particular
theme is triggering this problem so we definitely need to know that to be able
to reproduce this.
Comment 3 Ronald 2007-10-19 03:30:32 EDT
I already read the other posts from this bugzilla with probably the same
problem. There you said it was probably caused by the nvidia driver (which I use
too). So I submitted the reports running the vesa driver.

I'm not in Gnome. That is correct. I'm using XFCE with a new theme.

What does help is starting an 'empty' X-server with only xterm. Then starting
oowriter from xterm solves all the problems.

Could be the window manager (xfwm4)?

Btw, I can provide a kickstart file for a testing environment if you like.
Comment 4 Caolan McNamara 2007-10-19 03:45:39 EDT
I need to know the gtk theme, that's the key to this problem I suspect.
Comment 5 Ronald 2007-10-19 03:51:09 EDT
Since you said it was environmental related, I started to suspect the window
manager... It was the window manager, but more specific: It's theme. I tried the
following combinations:

metacity + clearlooks (works)
xfwm + clearlooks (works)
xfwm + thinice (this one is provided with xfce, fails too)
metacity + thinice (fails!)

So it's a theme issue. Both window managers do good under clearlooks but fail
under many other themes (like thinice and divinorum).

However, I got divinorum from a theme site so it doesn't count. But thinice
comes with XFCE (that is distributed with Fedora!), so that is really broken right?
Comment 6 Ronald 2007-10-19 03:51:32 EDT
Oh wait, so that is what you meant with collision, we posted at the same time :P
Comment 7 Ronald 2007-10-19 03:51:55 EDT
Yup you were right btw....
Comment 8 Caolan McNamara 2007-10-19 04:11:43 EDT
That's the one. I can see it now.
Comment 9 Caolan McNamara 2007-10-19 04:21:05 EDT
*** Bug 333271 has been marked as a duplicate of this bug. ***
Comment 10 Caolan McNamara 2007-10-19 04:21:21 EDT
*** Bug 299681 has been marked as a duplicate of this bug. ***
Comment 11 Caolan McNamara 2007-10-19 04:53:11 EDT
Eeek, wrong frees being used. firefox had the same problem as well. Sent patch
upstream. Will also include into fedora.
Comment 12 Caolan McNamara 2007-10-19 05:06:06 EDT
*** Bug 245651 has been marked as a duplicate of this bug. ***
Comment 13 Caolan McNamara 2007-10-19 05:07:43 EDT
Have fix, but cvs is locked at the moment
Comment 14 Caolan McNamara 2007-10-19 07:46:35 EDT
cvs unlocked, building
Comment 15 Caolan McNamara 2007-10-23 07:49:17 EDT
Should be squished in 2.3.0-6.5.fc8
Comment 16 Ronald 2007-10-23 15:00:57 EDT
Sorry, not fixed in 2.3.0-6.5.fc8:

openoffice.org-langpack-nl-2.3.0-6.5.fc8
openoffice.org-impress-2.3.0-6.5.fc8
openoffice.org-calc-2.3.0-6.5.fc8
openoffice.org-graphicfilter-2.3.0-6.5.fc8
openoffice.org-draw-2.3.0-6.5.fc8
openoffice.org-core-2.3.0-6.5.fc8
openoffice.org-writer-2.3.0-6.5.fc8

When I chose the thinice or some other skins. The program still terminates.
Minor difference is that I get no fancy window with traceback and stuff :(

Reopen bug right?
Comment 17 Fedora Update System 2007-10-24 03:13:39 EDT
openoffice.org-2.3.0-6.4.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'
Comment 18 Caolan McNamara 2007-10-24 04:13:08 EDT
If I actually *applied* the patch in > F7 we might have more success, that was
pretty stupid.
Comment 19 Ronald 2007-10-24 11:31:23 EDT
It's not such a big deal :P Tell me when you corrected it and I will try it :)
Comment 20 Caolan McNamara 2007-10-25 04:08:52 EDT
2.3.0-6.6.fc8 works for me now that the patch is applied
Comment 21 Ronald 2007-10-27 04:20:39 EDT
Confirmed, it also works with other themes that are not included in the default
installation. Good job :)
Comment 22 Fedora Update System 2007-11-01 17:20:03 EDT
openoffice.org-2.3.0-6.4.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.