Bug 338751 - anaconda unable to create LV
anaconda unable to create LV
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Depends On:
  Show dependency treegraph
Reported: 2007-10-18 16:17 EDT by Keith Grant
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-25 14:05:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Dump file from failed anaconda install. (82.92 KB, text/plain)
2007-10-18 16:17 EDT, Keith Grant
no flags Details

  None (edit)
Description Keith Grant 2007-10-18 16:17:45 EDT
Description of problem:

anaconda is unable to create an LV for installation on this system.

This system is using a 3ware 9550SXU for hardware RAID 5.  There are a total of
6 drives, each at about 290 GB, for a total of about 1.5TB.  The 3ware card
presents itself to linux as a 1.5TB scsi drive, mapped to /dev/sda.

I've tried installing with normal partitions, and it worked fine, but for some
reason, I am unable to create LVGs upon which to install the system.  I've tried
with varying sizes and configurations of the LVs, including some partitions
outside, or all partitions as part of the LVG.  In this situation, I'm afraid I
need to use LVM for its capability to grow partitions.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Begin installation on system with HW RAID 5 via 3ware 9550SXU.
2. In the disk management screen, select a custom partition configuration.
3. Create an LVM partition, and place logical volumes within it.
4. Press "Next"
Actual results:

Bug alert window.

Expected results:

anaconda proceeds to partition and format the RAID.

Additional info:

Attached is the anacdump.txt from the last time I attempted this.  You will see
the following drives:

/dev/hdb :  Optical drive with installation media.
/dev/sda :  RAID
/dev/sdb :  USB drive used to copy the dump file.

I apologize for the size of the log (1700 lines or so) but I'm not precisely
sure what's relevant here and what's not.
Comment 1 Keith Grant 2007-10-18 16:17:45 EDT
Created attachment 231521 [details]
Dump file from failed anaconda install.
Comment 2 Keith Grant 2007-10-18 17:34:21 EDT
I found a workaround.  I allowed the installer to create the partitions it
wanted (which were a 101MB /boot and everything else in an LVG) and then edited
all the partitions it had created to suit my size requirements, and added
anything that was missing.  No idea why this worked.
Comment 3 David Cantrell 2007-10-25 14:03:40 EDT
This problem has been fixed in Fedora and will be included in the next major
release of RHEL.

Bugzilla is not an official support channel for RHEL.  If you need this fix
included in RHEL, please contact your support representative who will escalate
it through the proper support channels.

Note You need to log in before you can comment on or make changes to this bug.