Bug 33890 - RH 7 fails to install on a SONY VAIO laptop
RH 7 fails to install on a SONY VAIO laptop
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i586 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-03-29 10:48 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-03-29 10:48:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-03-29 10:48:49 EST
I am trying to do a custom installation with the option "Everything" on my
SONY VAIO PCG-F370 laptop. Since my laptop uses a PCMCIA Ethernet link, I
have to boot from floppy the pcmcia.img, but the actual installation is 
from the local CD-ROM. It works fine (including self start and autoprobe
for X11) until it has to actually start installing packages, when I get
the nasty window saying "This is probably a bug. Dump this and send it to
This is the state dump:
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in
    if self.method.systemMounted (self.fstab, self.instPath,
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] +
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' +
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//win98

ToDo object:


If I choose Workstation installation with Automatic Partitioning then
RH 7 actually installs. I guess I could then install package after package
with gnoRPM, but it would be nice if I could get this installation the
short way.

Comment 1 Michael Fulbright 2001-03-29 11:24:56 EST

*** This bug has been marked as a duplicate of 18032 ***
Comment 2 Need Real Name 2001-03-30 13:00:24 EST
Despite the harsh rethoric againt RedHat people I've seen in the bugs list, the
install anaconda bug is not that bad. It is true that the update image disk does
not exist any more at its html link (which is annoying) but after a short
research on this site one can understand that basically for "Custom"
installation which forces "Manual disk partitioning" the preexinsting
Windows/DOS partitions should not be assigned mount points. I did just that and
I have a nice custom install on my SONY VAIO of RedHat 7.0. When up and running,
using linuxconf I could easily mount my Win98 partition, so no big deal.
I have tried Slackware 7.1 (try to exit X as a normal user !?), Corel Linux and
others. I don't want to even begin to say how involved it is to write GUI code
on Windows. Not even the path concept works decently for their "MS-DOS
terminal". So if not the only alternative, RedHat 7.0 is certainly one of the
best escape from the Windows bondage.

Note You need to log in before you can comment on or make changes to this bug.