Bug 33892 - Command-line up2date can break itself due to lack of dependencies
Summary: Command-line up2date can break itself due to lack of dependencies
Status: CLOSED DUPLICATE of bug 32301
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-29 16:16 UTC by Duncan
Modified: 2015-01-07 23:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-29 16:16:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Duncan 2001-03-29 16:16:41 UTC
Command-line mode up2date allows you to install a combination of updates 
which break up2date until you manually upgrade rpm-python.  Ie there 
should probably be a dependency in up2date or rpm on rpm-python.

Steps to Reproduce:
1. Install clean 7.0 system
2. Register on RHN
3. # up2date --nosig up2date rpm
4. Try to run up2date again.
	

Actual Results:  Up2date chucks a python error.

Expected Results:  Erm, it should still work...

Apologies for lack of detailed output, but this was on a machine I'm 
currently building and I was on VT with no mouse.

This can be worked around by manual rpm -Fvh rpm-python-4.0.2-7x.i386.rpm, 
but I'm going to leave it as "normal" severity because the whole point of 
up2date is that you shouldn't have to do that ;-)

Comment 1 Preston Brown 2001-03-31 02:50:55 UTC

*** This bug has been marked as a duplicate of 32301 ***

Comment 2 Duncan 2001-03-31 15:20:37 UTC
Yup.  Apologies for not finding any of the many other dups.  Must use broader
query criteria...


Note You need to log in before you can comment on or make changes to this bug.