Bug 33894 - tar -T option with --gzip backs up files more than once and/or documentation incorrect.
Summary: tar -T option with --gzip backs up files more than once and/or documentation ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tar (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-29 16:20 UTC by Need Real Name
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-29 16:20:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-03-29 16:20:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 95)


When using tar (GNU tar) version 1.13.17 with option -T <include-file> tar 
backs up more than the files specified in this file. 

For example:

If the directory /home/myacct/.netscape is specified in the -T file, 
tar backs up the entire directory rather than JUST the directory.
This ends up tarring more files than were specified in the -T file.

When the --gzip option is used, the problem appears to be more pronounced 
and seems to loop on large files backing them up multiple times.

Reproducible: Always
Steps to Reproduce:
1. echo "/home/myaccount/.netscape" > my.list
2. tar -cvPf my.tar -T my.list 
3. # You will notice that this not only backs up /home/myacct/.netscape, 
but also /home/myacct/.netscape/cache, etc.

I can reproduce the --gzip problem but the results vary from run to run. 
The -T file contains ! 9,000 fileIDs.

Actual Results:  tar dumped the /home/myacct/.netscape/cache/* directory 
and all it's contents including all the other directories and files 
under /home/myacct/.netscape.

It doesn't appear to do this with the other directory entries in the -T 
file.

Expected Results:  I expected the -T option to take the files listed in 
my.list and only back them up. 

It should have backed up the directory name: /home/myacct/.netscape
and nothing else.


The documentation says the file specified by -T contains the files that 
are to be created. 

Perhaps the documentation should state that entire directories get backed 
up.

This may not be as much of a bug as I first thought. But the --gzip option 
did cause freaky results which varied as I tried to re-create it.

Comment 1 Bernhard Rosenkraenzer 2001-05-22 20:10:44 UTC
The first part is intentional --

echo "/home/user/.netscape" >list
tar cf foo.tar -T list

does the same as

tar cf foo.tar /home/user/.netscape

and is supposed to do just that.

I can't reproduce the 2nd part on a 7.1 system.



Note You need to log in before you can comment on or make changes to this bug.