Bug 33908 - "useradd" "adduser" -p does not encrypt password
Summary: "useradd" "adduser" -p does not encrypt password
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: shadow-utils   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-29 17:20 UTC by Rogelio Noriega
Modified: 2014-03-17 02:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-29 17:20:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rogelio Noriega 2001-03-29 17:20:01 UTC
Problem: If "useradd" "adduser" is used with "-p" creates password 
in /etc/shadow as readable text. does not encrypt the password prior to 
adding to /etc/shadow.

Result: User cannot log in because password is un-hasshed

"linuxconf" and "passwd" work fine.

Comment 1 Bill Nottingham 2001-03-29 17:32:03 UTC
Please see the manpage:

       -p passwd
              The encrypted password, as returned by crypt(3).  The default
              is to disable the account.




Note You need to log in before you can comment on or make changes to this bug.