Bug 33910 - Cannot install on 3ware controller with RAID5
Summary: Cannot install on 3ware controller with RAID5
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-29 18:06 UTC by Jason Tibbitts
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-11 18:58:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jason Tibbitts 2001-03-29 18:06:37 UTC
I'm trying to bring up Wolverine on a machine with all of its disk behind a
3ware controller in one 538GB RAID5 array.

Bugs 30731 and 28029 are related, although this machine is not running SMP.
The problem is that Wolverine does not work on a RAID5 array (it works on a
striped array just fine).  I get large numbers of card aborts and the
install runs for hours without making progress.

As I would expect from bug 28029, with the boot disk and stageN image files
from Rawhide[1], the install progresses fine until post-install
configuration, where the installer segfaults (no Python backtrace
available).  I do not know if this is due to the 3ware controller or if it
is simply a problem with the installer.

I can boot into rescue mode using the same disk and stageN image files and
see the installation.  Unfortunately anaconda crashed before setting up
lilo or /etc/fstab so I'll have to go manually from here.

Is there currently any way to actually install any version of Red Hat with
all disk on a 3ware controller?

1) I have bootnet.img, netstg1.img, netstg2.img and stage2.img from March 
 19.  I am installing over HTTP.  I've also copied the kernel RPMS from  
Rawhide so if I could boot the system I should be able to run.

Comment 1 Michael Fulbright 2001-03-29 18:50:49 UTC
Matt or Alan, any ideas?

Comment 2 Alan Cox 2001-04-02 20:45:30 UTC
We had some fixes from 3ware. I dont know which QA tree they went back out in


Comment 3 Michael Fulbright 2001-04-11 18:58:06 UTC
We believe this is addressed in the current internal tree.

Comment 4 Jason Tibbitts 2001-04-17 20:58:56 UTC
Just to make a permanent record: Seawolf installs fine.


Note You need to log in before you can comment on or make changes to this bug.