Bug 33911 - latest kerberos package breaks LPRng
Summary: latest kerberos package breaks LPRng
Status: CLOSED DUPLICATE of bug 33580
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: LPRng   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-29 18:25 UTC by Bob Rose
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-29 18:25:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bob Rose 2001-03-29 18:25:32 UTC
Running P2/400, 256 MB, Kernel 2.2.17 fully updated (from RH RPMs) -

Retrieved from RH update site --
gnorpm-0.95.1-6.7x.i386.rpm
joe-2.8-43.7.i386.rpm
krb5-devel-1.2.2-3.i386.rpm
krb5-libs-1.2.2-3.i386.rpm
krb5-server-1.2.2-3.i386.rpm
krb5-workstation-1.2.2-3.i386.rpm
licq-1.0.2-2.i386.rpm
mutt-1.2.5i-8.7.i386.rpm
openssh-2.5.2p2-1.7.i386.rpm
openssh-askpass-2.5.2p2-1.7.i386.rpm
openssh-askpass-gnome-2.5.2p2-1.7.i386.rpm
openssh-clients-2.5.2p2-1.7.i386.rpm
openssh-server-2.5.2p2-1.7.i386.rpm
pam_krb5-1.30-1.i386.rpm
popt-1.6.2-7x.i386.rpm
sgml-tools-1.0.9-9.i386.rpm
slrn-0.9.6.4-0.7.i386.rpm
slrn-pull-0.9.6.4-0.7.i386.rpm
sudo-1.6.3p6-1.i386.rpm

and installed with "rpm -Uvh *.rpm"

After the instalation, all LPRng-related executables produce the text 
mentioned above -- "<program>: error loading shared libraries: <program>: 
undefined symbol: stat"

Ran "ldconfig -v" after rpm install above, and restarted the computer with 
the same error message - lpd wouldn't load on the restart.

In an effort to resolve the problem, I rebuilt the LPRng package with the 
command "rpm --rebuild LPRng-3.6.24-2.src.rpm" and noticed the LPRng 
dependency on the Kerberos libraries.  After the rebuild, all of the LPRng 
executables execute correctly.

Would suggest adding an LPRng package to the updates directory tree built 
against the latest krb5 package to prevent this problem for other users.

Comment 1 Jeremy Katz 2001-03-29 19:10:09 UTC

*** This bug has been marked as a duplicate of 33580 ***


Note You need to log in before you can comment on or make changes to this bug.