Bug 33915 - Samba + Quota allows user to pass hard limit; but with gibberish data not correct files
Samba + Quota allows user to pass hard limit; but with gibberish data not cor...
Status: CLOSED DUPLICATE of bug 31632
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-29 14:34 EST by Rob Landry
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-29 14:39:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The patch that was described in the bug report (3.36 KB, patch)
2001-03-29 14:35 EST, Rob Landry
no flags Details | Diff

  None (edit)
Description Rob Landry 2001-03-29 14:34:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.1-0.1.9 i686; en-US; 0.7)
Gecko/20010118




Reproducible: Always
Steps to Reproduce:
1. Setup SAMBA and QUOTA on the same machine with the same partition/share
2. Copy files from a remote windows machine to the samba machine
3. When you hit the soft limit "Disk Full" will appear but the file being
copied appears to be ok
4. Continue to copy files; each time you will get "Disk Full" however the
files copied will be of the correct size but will be gibberish; labeled
"ASCII TEXT" instead of correct file type.
5.  When you reach the hard limit it will continue the same behavior allow
the user to occupy more space on the drive than is available with quota
	

Actual Results:  See above

Expected Results:  When you hit the soft limit the file being copied should
continue to be copied (asuming is doesn't reach the hard limit) however any
additional copies will result in "Disk Full" on the windows machine

I have a patch that came from our Japanese office who recieved it from IBM;
this patch has been tested and results in the expected behaviour; however
we have not attempted to sanatize this patch for anything other than
correct end result behaviour.  If samba is left as is it will appear to
write the correct amount of data once you pass the quota limit; however the
data written is not the file sent cause a loss of data.

In addition the Japanese office has an outstanding request for a
fix/workaround to the above problem that they need an offical fix for.
Comment 1 Rob Landry 2001-03-29 14:35:12 EST
Created attachment 14143 [details]
The patch that was described in the bug report
Comment 2 Rob Landry 2001-03-29 14:39:53 EST
Bug #31632 is the entry from the Japanese office
Comment 3 Bill Nottingham 2001-03-29 17:16:49 EST
This patch is BROKEN.

See original bug report.

*** This bug has been marked as a duplicate of 31632 ***

Note You need to log in before you can comment on or make changes to this bug.