Bug 33930 - LPR segfaults on load on Fisher ia64
LPR segfaults on load on Fisher ia64
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.3
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-29 15:32 EST by Steven Cook
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-21 11:18:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steven Cook 2001-03-29 15:32:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Windows NT 5.0; U)


After setting up a local USB printer using printtool, attempting to start LPR generates a segfault.

Reproducible: Always
Steps to Reproduce:
1.attach an USB Printer to the system
2.configure the printer using printtool
3.start LPR
	

Actual Results:  segfault

Expected Results:  LPR should load, and printer should be usable.
Comment 1 Steven Cook 2001-03-29 15:46:20 EST
This was found on W460GXBS2 workstation system, BIOS 99
Comment 2 Bill Nottingham 2001-03-29 16:20:39 EST
This is fixed in the current LPRng package (3.7.4-21).
Comment 3 Steven Cook 2001-05-08 17:33:27 EDT
Issue resurfaced with LPR version LPRng 3.7.4-22

When I tell the printtool to reset the LPR (Via the pulldown menu), It reports
that the lpr deamon was reset correctly. If I then try to run the tests, I get a
failure.

I went to a text console and tried to '/etc/init.d/lpr stop ; /etc/init.d/lpr
start' manualy. Lpr, the first time I tried this, Segfaulted my machine. Now, it
complains on not having a config for my printer.

The printer I have is an Epson Stylus Color 740, USB connection. If I run a
'/usr/games/fortune > /dev/usb/lp0', It prints out a fortune for me.
Comment 4 Steven Cook 2001-05-08 17:34:34 EDT
This was last tested on the Wolverine build. (which is where the LPRng 3.7.4-22
came from.
Comment 5 Preston Brown 2001-05-21 11:17:59 EDT
Crutcher, I want you to look into this today.
Comment 6 Crutcher Dunnavant 2001-05-22 11:11:00 EDT
fixed
Comment 7 Crutcher Dunnavant 2001-05-22 14:46:46 EDT
cannot reproduce crashes with LPRng-3.7.4-22, but found nasty problems in
printconf's magicfilter copy. The relevant fixes are in printconf-0.2.15

Note You need to log in before you can comment on or make changes to this bug.