Bug 33930 - LPR segfaults on load on Fisher ia64
Summary: LPR segfaults on load on Fisher ia64
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: ia64 Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-29 20:32 UTC by Steven Cook
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-21 15:18:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steven Cook 2001-03-29 20:32:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Windows NT 5.0; U)


After setting up a local USB printer using printtool, attempting to start LPR generates a segfault.

Reproducible: Always
Steps to Reproduce:
1.attach an USB Printer to the system
2.configure the printer using printtool
3.start LPR
	

Actual Results:  segfault

Expected Results:  LPR should load, and printer should be usable.

Comment 1 Steven Cook 2001-03-29 20:46:20 UTC
This was found on W460GXBS2 workstation system, BIOS 99

Comment 2 Bill Nottingham 2001-03-29 21:20:39 UTC
This is fixed in the current LPRng package (3.7.4-21).

Comment 3 Steven Cook 2001-05-08 21:33:27 UTC
Issue resurfaced with LPR version LPRng 3.7.4-22

When I tell the printtool to reset the LPR (Via the pulldown menu), It reports
that the lpr deamon was reset correctly. If I then try to run the tests, I get a
failure.

I went to a text console and tried to '/etc/init.d/lpr stop ; /etc/init.d/lpr
start' manualy. Lpr, the first time I tried this, Segfaulted my machine. Now, it
complains on not having a config for my printer.

The printer I have is an Epson Stylus Color 740, USB connection. If I run a
'/usr/games/fortune > /dev/usb/lp0', It prints out a fortune for me.

Comment 4 Steven Cook 2001-05-08 21:34:34 UTC
This was last tested on the Wolverine build. (which is where the LPRng 3.7.4-22
came from.

Comment 5 Preston Brown 2001-05-21 15:17:59 UTC
Crutcher, I want you to look into this today.


Comment 6 Crutcher Dunnavant 2001-05-22 15:11:00 UTC
fixed

Comment 7 Crutcher Dunnavant 2001-05-22 18:46:46 UTC
cannot reproduce crashes with LPRng-3.7.4-22, but found nasty problems in
printconf's magicfilter copy. The relevant fixes are in printconf-0.2.15


Note You need to log in before you can comment on or make changes to this bug.