This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 339441 - DVD device missing at a specific point during the installation.
DVD device missing at a specific point during the installation.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 06:48 EDT by Micke
Modified: 2007-12-18 14:01 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-18 14:01:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The requested syslog (30.25 KB, text/plain)
2007-10-25 14:56 EDT, Micke
no flags Details
The requested anaconda log (21.52 KB, text/plain)
2007-10-25 14:56 EDT, Micke
no flags Details

  None (edit)
Description Micke 2007-10-19 06:48:33 EDT
Description of problem:
DVD device missing at a specific point during the installation.

Version-Release number of selected component (if applicable):
F-7-x86_64-DVD.iso (sha 7cdbd9e1bed9cc9ce2c7970abeaca4da08d2994a)

How reproducible:
Every time I've tried...

Steps to Reproduce:
I have a new ASUS P2-M2A690G 690G SKT-AM2 with 320GB SATA HD and IDE DVD/RW. I
have created a DVD of F-7-x86_64-DVD.iso. There is an existing XP installation
on the HD. Basically, I:
1. Boot the DVD.
2. Customize the default layout by shrinking "/" to 60GB.
3. Click OK as far as I can.
The installer then creates the partitions and transfers some image to the HD. 

After this it pops up a box stating that it can not find rpm xxxx
(Retry/Reboot). (Different rpm depending on packages selected)

If I switch to a console, I can not find the slightest trace of the DVD. No
device, no nothing. dmesg shows lots of failed attempts on sr0, but that device
does not exist.
  
Actual results:


Expected results:


Additional info:
I think the ASUS P2-M2A690G 690G SKT-AM2 is rather new...
Comment 1 Chris Lumens 2007-10-24 14:34:15 EDT
Please attach /tmp/anaconda.log and /tmp/syslog to this bug report.
Comment 2 Micke 2007-10-25 14:56:00 EDT
Created attachment 237761 [details]
The requested syslog
Comment 3 Micke 2007-10-25 14:56:43 EDT
Created attachment 237771 [details]
The requested anaconda log
Comment 4 Micke 2007-10-25 15:01:22 EDT
From what I can gather the DVD device exists as /dev/scd0 and is working
perfectly. Running sha1sum on the DVD from the console gives the correct result
(limiting size with dd first of course).
Comment 5 Chris Lumens 2007-10-25 16:51:57 EDT
This doesn't look so good:

<6>sr 1:0:0:0: SCSI error: return code = 0x08000002
<6>sr0: Current: sense key: Medium Error
<6>    Additional sense: No seek complete
<6>Info fld=0x176b1
<4>end_request: I/O error, dev sr0, sector 383684
<3>Buffer I/O error on device sr0, logical block 95921
<6>sr 1:0:0:0: SCSI error: return code = 0x08000002
<6>sr0: Current: sense key: Medium Error
<6>    Additional sense: No seek complete
<6>Info fld=0x176b2
<4>end_request: I/O error, dev sr0, sector 383688
<3>Buffer I/O error on device sr0, logical block 95922
<3>Buffer I/O error on device sr0, logical block 95923
<3>Buffer I/O error on device sr0, logical block 95924
<3>Buffer I/O error on device sr0, logical block 95925
<3>Buffer I/O error on device sr0, logical block 95926
<3>Buffer I/O error on device sr0, logical block 95927
<3>Buffer I/O error on device sr0, logical block 95928

You said you ran sha1sum on the DVD and it returns the correct answer.  Have you
also tried the media check within anaconda?  It sounds like you've either got
bad media or hardware, or there's a kernel driver problem here.  These messages
would certainly explain why anaconda's bailing out trying to read packages.
Comment 6 Micke 2007-10-25 18:25:32 EDT
Anaconda's media check performed a few times during testing. No problems
reported. I can sha1sum the DVD at the same point as the installer can't find
anything. I can sha1sum the specific rpm the pop-up is complaining about.

(Is it possible to quickly brief me on the relation between the names sr0 and
scd0? Can I find out anything useful for the name sr0?)
Comment 7 Micke 2007-10-26 02:56:00 EDT
OK, found a way to get it working:
# mkdir /mnt/source
# mount /dev/scd0 /mnt/source
then click "Retry". The installation continues and the resulting systems seems
to boot.
Comment 8 Chris Lumens 2007-12-18 14:01:57 EST
This should be working in rawhide due to totally new device management code that
was recently committed.

Note You need to log in before you can comment on or make changes to this bug.