Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 339541 - xfs performance leak
xfs performance leak
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-xfs (Show other bugs)
5.0
i386 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 07:47 EDT by Ulrich Seidl
Modified: 2013-11-05 14:17 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-05 14:17:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (2.05 KB, text/plain)
2008-01-07 04:58 EST, Ulrich Seidl
no flags Details
Xorg.0.log (21.01 KB, text/plain)
2008-01-07 04:59 EST, Ulrich Seidl
no flags Details

  None (edit)
Description Ulrich Seidl 2007-10-19 07:47:37 EDT
Description of problem:
In RedHat ES 5, the xfs sometimes produces high cpu loads.

Version-Release number of selected component (if applicable):
xorg-x11-xfs 1.0.2

How reproducible:
always

Steps to Reproduce:
1. open a "wish"
2. enter "label .a -font {symbol 12} -text [ format %c 127 ]"
3. xfs now causes a high cpu load for some time. Can be checked e.g. with "top"
  
Actual results:
high cpu load after fontserver request

Expected results:
cpu load should not be higher as with RedHat ES 3 / 4 xfs.

Additional info:
Comment 1 Matěj Cepl 2008-01-06 17:53:39 EST
I cannot reproduce it with xorg-x11-xfs-1.0.2-4 in kvm virtual RHEL5 machine
upgraded to the latest packages.
Comment 2 Matěj Cepl 2008-01-06 17:54:02 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Ulrich Seidl 2008-01-07 04:58:54 EST
Created attachment 290940 [details]
xorg.conf
Comment 4 Ulrich Seidl 2008-01-07 04:59:40 EST
Created attachment 290941 [details]
Xorg.0.log
Comment 6 Adam Jackson 2013-11-05 14:17:47 EST
No further X updates are planned for RHEL5.

Note You need to log in before you can comment on or make changes to this bug.