Bug 3397 - NFS breaks on upgrade from 5.2 but not on full install
NFS breaks on upgrade from 5.2 but not on full install
Status: CLOSED DUPLICATE of bug 3241
Product: Red Hat Linux
Classification: Retired
Component: nfs-server (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-10 18:00 EDT by ajb
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-11 09:30:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ajb 1999-06-10 18:00:13 EDT
I have several machines formerly running RH 5.2

On a few, I did a full install to RH 6.0
On the others, I did an upgrade install.

When the installs/upgrades were complete, we
discovered that the systems that were "upgraded"
were no longer able to serve NFS mounts.  In particular,
when another client tried to mount one of the upgraded
system's exported filesystems, the following error was
returned:

    mount: RPC: Program not registered

Tracking things down further, we discovered that
mountd was running properly on the machines that
were "installed", but missing (i.e. not running)
on the machines that were "upgraded".

Here's the output of rpcinfo for a machine that
was "installed":

/usr/sbin/rpcinfo -p node8
   program vers proto   port
    100000    2   tcp    111  rpcbind
    100000    2   udp    111  rpcbind
    100024    1   udp    987  status
    100024    1   tcp    989  status
    100011    1   udp    998  rquotad
    100011    2   udp    998  rquotad
    100005    1   udp   1008  mountd
    100005    1   tcp   1010  mountd
    100005    2   udp   1013  mountd
    100005    2   tcp   1015  mountd
    100005    3   udp   1018  mountd
    100005    3   tcp   1020  mountd
    100003    2   udp   2049  nfs
    100021    1   udp   1026  nlockmgr
    100021    3   udp   1026  nlockmgr
    100021    1   tcp   1024  nlockmgr
    100021    3   tcp   1024  nlockmgr
    300019    1   tcp    624  amd
    300019    1   udp    625  amd

And, here's the rpcinfo output of a machine
that was "upgraded":

/usr/sbin/rpcinfo -p node3
   program vers proto   port
    100000    2   tcp    111  rpcbind
    100000    2   udp    111  rpcbind
    100021    1   udp   1024  nlockmgr
    100021    3   udp   1024  nlockmgr
    100021    1   tcp   1024  nlockmgr
    100021    3   tcp   1024  nlockmgr

Please note that before the upgrades/installs
all of our machines were running properly as
NFS servers.  Following the upgrades/installs
we confirmed that the proper entries were in
/etc/fstab and /etc/exports.  This problem
has been consistently observed on several
formerly working, but now "upgraded" to 6.0
systems.

So, what's wrong? And, why should upgrading disable
the ability to serve NFS?

	Thanks,

	Alan Broder
	ajb@woti.com
Comment 1 Jeff Johnson 1999-06-11 09:30:59 EDT
*** This bug has been marked as a duplicate of 3241 ***

Note You need to log in before you can comment on or make changes to this bug.