Red Hat Bugzilla – Bug 339731
wrong libxklavier buildreq
Last modified: 2007-11-30 17:12:19 EST
Apparently version of libxklavier specified as BuildReq in control-center.spec
should be bumped.
I'm trying to rebuild control-center from devel on F7 box:
$ rpmbuild --rebuild control-center-2.20.1-1.fc8.src.rpm
checking for LIBGNOMEKBD... configure: error: Package requirements (libgnomekbd
>= 0.1 libxklavier >= 3.2) were not met:
Requested 'libxklavier >= 3.2' but version of libxklavier is 3.1
$ rpm -qp --requires control-center-2.20.1-1.fc8.src.rpm | grep libxk
libxklavier-devel >= 1.14
BuildReq: libxklavier-devel >= 3.2
Version-Release number of selected component (if applicable):
Finally -- is there a way to auotmate the generations those BuildReqs from the
configure.ac of the package itself? I heard that AltLinux guys are doing just
that for their spec files...
there's a patch laying around to pull buildreqs for pkg-config files, but I
don't think it's on the radar to get applied anytime soon.
I'll commit the BuildReq change, but probably won't do a build until there's a
more pressing reason.
Sure, doesn't make sense to rebuild per se, just fix the spec. Thanks!