Bug 339811 - 'Xvnc -render' crashes
'Xvnc -render' crashes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 10:57 EDT by Tim Waugh
Modified: 2013-04-30 19:37 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.1.2-19.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-29 15:06:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2007-10-19 10:57:40 EDT
Description of problem:
Running 'Xvnc -render' crashes with a segfault.

Version-Release number of selected component (if applicable):
vnc-server-4.1.2-18.fc7

How reproducible:
100%

Steps to Reproduce:
1.Xvnc -render
  
Actual results:
Segfault

Expected results:
Either run without render extension (as in FC-6), or give an explanation of how
better to use that option if its meaning has changed.

Additional info:
Comment 1 Adam Tkac 2007-10-22 04:53:50 EDT
I believe problem is in Composite extension because it needs RENDER extension
(so you can't use Composite without RENDER). Could you please try start Xvnc
with '-render -extension Composite'?
Comment 2 Tim Waugh 2007-10-22 05:03:53 EDT
Yes, 'Xvnc -render -extension Composite :5' does not crash.
Comment 3 Tim Waugh 2007-10-22 12:06:37 EDT
NOTABUG?  But it worked fine in Fedora Core 6 without having to disable Composite.
Comment 4 Adam Tkac 2007-10-23 08:45:37 EDT
Ok, I will disable Composite extension in next build because it never worked
properly and also main X disable it in Xvfb.
Comment 5 Fedora Update System 2007-10-29 15:06:13 EDT
vnc-4.1.2-19.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.