Bug 339811 - 'Xvnc -render' crashes
Summary: 'Xvnc -render' crashes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: vnc
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Adam Tkac
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-19 14:57 UTC by Tim Waugh
Modified: 2013-04-30 23:37 UTC (History)
1 user (show)

Fixed In Version: 4.1.2-19.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-29 19:06:16 UTC
Type: ---


Attachments (Terms of Use)

Description Tim Waugh 2007-10-19 14:57:40 UTC
Description of problem:
Running 'Xvnc -render' crashes with a segfault.

Version-Release number of selected component (if applicable):
vnc-server-4.1.2-18.fc7

How reproducible:
100%

Steps to Reproduce:
1.Xvnc -render
  
Actual results:
Segfault

Expected results:
Either run without render extension (as in FC-6), or give an explanation of how
better to use that option if its meaning has changed.

Additional info:

Comment 1 Adam Tkac 2007-10-22 08:53:50 UTC
I believe problem is in Composite extension because it needs RENDER extension
(so you can't use Composite without RENDER). Could you please try start Xvnc
with '-render -extension Composite'?

Comment 2 Tim Waugh 2007-10-22 09:03:53 UTC
Yes, 'Xvnc -render -extension Composite :5' does not crash.

Comment 3 Tim Waugh 2007-10-22 16:06:37 UTC
NOTABUG?  But it worked fine in Fedora Core 6 without having to disable Composite.

Comment 4 Adam Tkac 2007-10-23 12:45:37 UTC
Ok, I will disable Composite extension in next build because it never worked
properly and also main X disable it in Xvfb.

Comment 5 Fedora Update System 2007-10-29 19:06:13 UTC
vnc-4.1.2-19.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.