Bug 33989 - X4.0.3 Font Display Very Garbled/Wrong
Summary: X4.0.3 Font Display Very Garbled/Wrong
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL: http://www.zip.com.au/~j_m/x4bug/
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-30 04:08 UTC by Need Real Name
Modified: 2007-04-18 16:32 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-03-30 04:43:08 UTC


Attachments (Terms of Use)

Description Need Real Name 2001-03-30 04:08:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)


X 4.0.3 Has trouble displaying almost all text, 
See http://www.zip.com.au/~j_m/x4bug/bad-fonts-etc.jpg

Reproducible: Always
Steps to Reproduce:
1. Have XFree86 4.0.3 Installed on RH7, with SiS AGP 3d card.
2. Have XF86Config (http://www.zip.com.au/~j_m/x4bug/xf86config.1.txt)
3. startx
	

Actual Results:  Garbled Text (http://www.zip.com.au/~j_m/x4bug/bad-fonts-
etc.jpg)

Expected Results:  http://gtk.themes.org/php/pic.phtml?
src=themes/gtk/shots/982030697.jpg
(would be nice)

X 4.0.3 Has trouble displaying almost all text, and some graphics.
A screenshot of the problem is available 
(http://www.zip.com.au/~j_m/x4bug/bad-fonts-etc.jpg)
Notice how the font problem does not effect Nautilus icons and text, but 
does effect _all_ other programs, and is very bad on all gtk+ apps. (gtk 
is 1.2.9)

The startx output is (http://www.zip.com.au/~j_m/x4bug/xoutput.txt)
Ive played around with it a fair bit, loading modules and fontpaths etc.  
You will notice a couple of errors in the in the output file, 
but I belive that this is not associated with the problem. 

Graphics on the large part remain unnafected, only visually "heavy" apps 
(like mozilla) remain "sticky" on the desktop after they have been closed 
down. I belive this could be a seperate issue, but i'm mentioining it 
anyway. :-)

I believe it may have something to do with the Xrender (aa) extention, or 
the way the xfs is loaded but I dont know how to test/disable this. 

I was going to get the latest KDE & QT (as this has the aa enabled)
to see if i can get some action, but thats going to take its time on my 
dialup....

Does anyone has any other ideas, tests, troubleshooting tips, or need more 
info?

Cheers. JM

Comment 1 Need Real Name 2001-03-30 04:43:04 UTC
Additional Info:

My upgrade went from X3.3.6 to X4.0.2,
I compiled X4.0.2, and then did the X4.0.3 binary upgrade straight away
without testing, so I am unsure if the problem effects both versions.



Comment 2 Mike A. Harris 2001-03-30 09:12:23 UTC
You are using a non Red Hat release of 4.0.3 plopped on top of 4.0.2.
XFree86 4.0.3 RPM's were out about 16 hours after 4.0.3 was official so...

The problem is with your setup most likely.  Use the latest Rawhide version
instead, or to stay current:

ftp://people.redhat.com/mharris

Just a note for the future, please don't provide URL's to gifs as the
URL may disappear before the bug ever gets fixed.  Instead, use the
file attach link below and attach the screenshot or whatever.  That makes
it easiest for us as we don't need to rely on some remote server that may
disappear, etc..

Thanks.

Comment 3 Need Real Name 2001-04-02 02:09:38 UTC
Fixed with 
Option "no_accel"




Note You need to log in before you can comment on or make changes to this bug.