Bug 339981 - anaconda hacks for kde*-libs multilib changes
anaconda hacks for kde*-libs multilib changes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
: 346211 (view as bug list)
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-10-19 12:41 EDT by Jochen Schmitt
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-25 09:34:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jochen Schmitt 2007-10-19 12:41:01 EDT
I have try to get my rawhide installation uptodate. Unfortunately I have got
a error message, that kdegraphics depends on libpoppler-qt.sq.1.

I have downloaded the current version of poppler-qt from the devel branch and
found out, that this package contains libpoppler-qt.so.2.

So it may be nice, if you can rebuild the package for solving the broken
dependencies.
Comment 1 Rex Dieter 2007-10-19 12:54:58 EDT
Rawhide is fine for me:

$rpm -q kdegraphics poppler-qt
kdegrahpics-3.5.8-2.fc8
libpoppler-qt-0.6-2.fc8

$ rpm -qR kdegraphics | grep poppler
libpoppler-qt.so.2
Comment 2 Jochen Schmitt 2007-10-19 14:21:04 EDT
Hello. I have done some investigation to find out, why this issue was happen:

As a starting point of my update I havd:

kdegraphics-3.5.7-3.x86_64
kdegraphics-3.5.7-3.i386

But the endpoint of the update path was:

kdegraphics-3.5.8-2.x86_86

So the old i386 release of kegraphics still remain on the system, but
poppler-qt.i386 was updated to a newer release which caused the broken library
dependency.
Comment 3 Rex Dieter 2007-10-19 14:47:49 EDT
Hmm, rawhide/upgrade victim.
kdegraphics is no longer multilib'd.  
Not sure how best to handle cases like this.
Comment 4 Rex Dieter 2007-10-19 15:03:18 EDT
Talked it over with f13, looks like we need to add some anaconda magic to
properly handle the upgrade (at least until rpm can do per-arch Obsoletes).
Comment 5 Rex Dieter 2007-10-19 15:13:50 EDT
A bunch of kde (and related) pkgs that once were multilib'd, aren't anymore due
to kde*-libs pkg splits.  The list includes:
kdeaccessibility
kdeaccessibility-devel
kdebase
kdeedu
kdegraphics
kdemultimedia
kdemultimedia-extras
kdenetwork
kdesdk
kdeutils
kdeutils-devel
kdewebdev

ugh.
Comment 6 Jochen Schmitt 2007-10-19 16:13:18 EDT
I have opened BZ 340271 agains yum. because I think this is the right place to
handled such issues.
Comment 7 Jeremy Katz 2007-10-22 13:48:51 EDT
Need to add things to the upgrade blacklist in upgrade.py
Comment 8 Jeremy Katz 2007-10-22 16:41:08 EDT
Added
Comment 9 Jeremy Katz 2007-10-23 00:02:51 EDT
*** Bug 346211 has been marked as a duplicate of this bug. ***
Comment 10 Rex Dieter 2007-10-25 06:28:45 EDT
doh, I missed one (sorry):
kdepim
Comment 11 Jeremy Katz 2007-10-25 09:34:44 EDT
Added

Note You need to log in before you can comment on or make changes to this bug.