Bug 340071 - package install doesn't start the service
package install doesn't start the service
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 13:14 EDT by cje
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 13:56:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cje 2007-10-19 13:14:09 EDT
installing the package installs the libvirtd service and sets it to start
automatically but doesn't actually start it.
Comment 1 Daniel Berrange 2007-10-19 13:16:48 EDT
Automatically starting services from a %post script is a pure evil & forbidden.
The RPM installation could be being done in a chroot for the purposes of
building other dependant packages & you defintely do not want this starting daemons.
Comment 2 cje 2007-10-19 13:51:30 EDT
okay, but would you agree that this is somewhat confusing/frustrating for new users?

surely the "chroot for building stuff" is the more uncommon scenario which
should be tested for in the script, rather than throwing out the idea because
it's evil.

would it be okay if the script checked for chroot and started the service if it
wasn't chrooted?  or are there a million other gotchas queued up behind that one?

sorry for pestering/reopening - i'm not after a full explanation (i'm sure
that's on the web somewhere) - just a little bit more info.  tell me there's a
million fiddly little problems that cause the overall "evil" status and that'll
be fine - i'll go find some other way of dealing with it.

maybe this should be a plugin for yum/pirut/packagekit rather than troubling rpm
or individual package maintainers with all the security implications?

i'm just thinking it'd be nice if all apps helped the user as much as possible
following an install and if we start down that road then the code and rules
required by yum would get insanely complicated.  better to set a precedent and
create a supporting structure to help apps install themselves.

why pick on libvirt?  well, you'd have to start somewhere and that's where i was
when the thought occurred.
Comment 3 Daniel Berrange 2007-10-19 13:56:08 EDT
Take this discussion to fedora-devel-list if you want to get into it. This is
not appropriate for bugzilla.

Note You need to log in before you can comment on or make changes to this bug.