Bug 3401 - Upgrade fails
Upgrade fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-10 21:53 EDT by dhughes
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-10 15:03:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dhughes 1999-06-10 21:53:17 EDT
Upgrade of a running Red Hat 5.2 system to 6.0
fails after asking if any SCSI devices (no) with the message
the the mount failed, device busy.

separate 10meg boot partition on an ide device below the
1024 cylinder boundry.

same failure on 3 different systems.
Comment 1 Dale Lovelace 1999-06-11 14:47:59 EDT
Are you using a CdRom to upgrade? Booting from the Cd or from a
floppy? Is this by any chance a hard drive install, ie the RPMs are
located on the hard drive you are upgrading?

------- Email Received From  "Don Hughes" <dhughes@microtechniques.com> 06/12/99 13:03 -------
Comment 2 Jay Turner 1999-06-14 14:01:59 EDT
Try booting the upgrade process from cdrom rather than booting from
the boot disks that you downloaded.  There is a possibility that the
boot disks are corrupt and that is leading to the problem that you are
seeing.

------- Email Received From  "Don Hughes" <dhughes@microtechniques.com> 06/14/99 22:09 -------


------- Additional Comments From   06/15/99 03:34 -------
I had exactly the same problem when I tried to upgrade from RH 5.2
(heavily updated already by hand, including the kernel to the latest
2.2 available at the moment).
I tried the following (all combinations):
- booting either from floppy or from a bootable CD I have created,
using both the boot.img file provided in the RHL 6.0 RPMS and the one
provided as update
- installing from a HDD partition (/dev/hdc11, 1 GB, only used to
store install kits, usually unmounted!) or from the above mentioned CD

The solution was to manually umount /mnt, after the first 'device
busy' message, hit 'retry' and afterwards all worked fine. Looks to me
like the bug already mentioned on bugzilla (#2499/2504/2505 and so on)


Manuel Wolfshant (wolfy67@yahoo.com)

------- Email Received From  "Don Hughes" <dhughes@microtechniques.com> 06/16/99 20:45 -------
Comment 3 Jay Turner 1999-06-30 10:19:59 EDT
This issue has been forwarded to a developer for further action.

Note You need to log in before you can comment on or make changes to this bug.