Bug 340181 - bug mail not reaching internal mailing list
bug mail not reaching internal mailing list
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Email Notifications (Show other bugs)
2.18
All Linux
low Severity low (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 13:43 EDT by David Lehman
Modified: 2013-06-23 22:49 EDT (History)
0 users

See Also:
Fixed In Version: 2.18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:45:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lehman 2007-10-19 13:43:15 EDT
Description of problem:
Bug mail to anaconda-maint-list@redhat.com is not being delivered.

Version-Release number of selected component (if applicable):
production bugzilla (not a beta)

How reproducible:
Always, I guess.

Steps to Reproduce:
1. Perform any action that generates an email notification to
anaconda-maint-list@redhat.com
2.
3.
  
Actual results:
list subscribers get no mail

Expected results:
list subscribers get mail

Additional info:
Comment 1 David Lehman 2007-10-19 13:51:34 EDT
Seems as though the list itself is functioning correctly, FWIW.
Comment 2 David Lawrence 2007-10-19 14:06:04 EDT
Please send an email to helpdesk@redhat.com asking to verify that
anaconda-maint-list@redhat.com is not being blocked for external mail delivery.
Bugzilla is at a colo and is considered an external site and the mail server
blocks outside mail to users internally by default. Also make sure the
list has bugzilla@redhat.com as subscribed so that once mail is allowed
in it can post to the list.

Dave
Comment 3 David Lehman 2007-10-19 15:38:55 EDT
The list is not blocked according to helpdesk. They have passed it on to
"Systems" to take a look at.

I should have also mentioned that this began Wednesday morning sometime. It
worked fine until then.
Comment 4 David Lawrence 2007-10-19 15:45:20 EDT
Ah, our bad. When you said Wednesday it made me remember a change we pushed to
production around that time. We added a fix to the mail code that will block
email being sent to accounts that are marked as disabled. I checked the settings
for the anaconda list and it was in fact set to disabled. This was originally
because we didnt want people to actually log in with it, just use it for bug
assignments. But with the new fix on Wed, it also stops emails. So I have set
the account to enabled and now email should be sent again.

Sorry for the trouble. 
Dave

Note You need to log in before you can comment on or make changes to this bug.