Bug 34029 - diff and cmp has problems with big files
Summary: diff and cmp has problems with big files
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: diffutils   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-30 07:50 UTC by Erika Mustermann
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-30 07:54:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Erika Mustermann 2001-03-30 07:50:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.7C-SGI [en] (X11; I; IRIX 6.5 IP32)


Using 'diff' or 'cmp' on files bigger than 2GB you receive the
error message: Value too large for defined data type

Reproducible: Always
Steps to Reproduce:
1. dd if=/dev/zero of=testfile seek=2050 bs=1024k count=1
2. diff testfile /dev/null
  => Value too large for defined data type
3. cmp testfile /dev/null
  => Value too large for defined data type

	

Actual Results:  The errormessage 'Value too large for defined data type'.


Expected Results:  Obviously I would like to see the diff. :-)

At ftp://alpha.gnu.org/gnu/diffutils-2.7.2.tar.gz is a fixed
version waiting since 1998 for it's usage.

Comment 1 Tim Waugh 2001-05-02 21:25:25 UTC
Fixed in diffutils-2.7.2-1.



Note You need to log in before you can comment on or make changes to this bug.