Bug 340371 - MXUNIT parameter too small
MXUNIT parameter too small
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gcc3 (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 15:39 EDT by kirk l. holub
Modified: 2013-03-21 15:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-21 15:01:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kirk l. holub 2007-10-19 15:39:33 EDT
Description of problem:
A FORTRAN program we use in a production environment fails after
trying to open too many files.  We can work around the problem my
updating the file libf2c/libI77/fio.h  and replacing
#define MXUNIT 100
with line:
#define MXUNIT 10000
and then, of course, rebuilding and reinstalling gcc.

Although this works, we would like to avoid having to repeat this
produre whenever gcc is updated.  And since we update the release
number when we rebuild the rpm, just to keep things straight, our
system in now out of sync with respect to Red Hat Network.

So, the bottom line, would it be possible to increase MXUNIT in the
production release of gcc?

Thanks.

--Kirk  

Version-Release number of selected component (if applicable):
gcc-3.2.3

How reproducible:
Always

Steps to Reproduce:
1. not applicable
    

Actual Results:  Our production FORTRAN code stops due to lack of file
handles

Expected Results:  Our program should have run to completion.

Additional info:
This defect was posted as 127157 in July 2004.  That posting was just closed
simply because it was registered against RHEL3.  This same defect continues to
impact our operations when using RHEL5+.
Comment 1 Jeff Law 2013-03-21 15:01:46 EDT
There are no plans to issue additional Red Hat Enterprise Linux updates for the older gcc-3 based toolchains which contain the g77 Fortran front-end and associated libf2c runtime.

The standard compilers on Red Hat Enterprise Linux 5 (gcc-4.1 and gcc-4.4 based) contain the gfortran Fortran front-end and libgfortran.  The libgfortran runtime dynamically manages units and as far as I can tell has no builtin maximum unit number.

Note You need to log in before you can comment on or make changes to this bug.