Bug 3405 - mkbootdisk fails with Mylex DAC960
mkbootdisk fails with Mylex DAC960
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mkbootdisk (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-11 15:07 EDT by jjs
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-12 16:06:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jjs 1999-06-11 15:07:33 EDT
mkbootdisk does not know how to handle Mylex DAC960 devices.
It creates /dev/c0d0p1 device file to emergency booti disk,
while the correct location of that device file would be
/dev/rd/c0d0p1.
It does put the right location (/dev/rd/c0d0p1) to
lilo.conf.

Because of this bug lilo does not install itself to bootdisk
and that bootdisk does not work.

Broken bootdisks can be repaired by mounting them to a linux
machine and moving the device file to right location and
reinstlling lilo to the floppy.
Comment 1 Jay Turner 1999-06-14 13:56:59 EDT
We are aware of this problem and are in the process of putting
together a fix.
Comment 2 Bill Nottingham 1999-08-12 16:06:59 EDT
I believe this is fixed in the latest mkbootdisk (1.2.1-1).
Comment 3 Josh Zimmerman 2000-06-13 22:41:37 EDT
When I run mkbootdisk the following error pops up saying that it cannot find 
the mkinitrd file
I installed mkbootdisk 1.2.5-3 and mkinitrd 2.4.1-2 off a 6.2 disk and still 
brings up the 
usage:mkinitrd [--version][-v][-f]....etc.

Comment 4 Josh Zimmerman 2000-06-19 17:39:03 EDT
Clarification to above posting:
I am running RedHat 6.0 and took the mkinitrd file form a 6.2 disk 
when I enter:
mkbootdisk --device /dev/fd0 2.2.5-15
it starts to make the disk
while it is making the disk it throws out:

usage: mkinitrd ......as above
and makes the rest of the disk.

when trying to boot the disk it reads it and starts to boot it but will not 
find the SCSI drives on the computer.

I did not type initrd anywhere in the mkbootdisk command to throw a usage error 
out. 

Everything from what I posted above has stayed the same.

Note You need to log in before you can comment on or make changes to this bug.