Bug 340511 - EXA acceleration causes graphic corruption
EXA acceleration causes graphic corruption
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 16:30 EDT by Jon Nettleton
Modified: 2008-03-21 18:12 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.3.0.0-44.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-21 18:12:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upstream patch (690 bytes, patch)
2007-10-22 13:01 EDT, Matěj Cepl
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 12520 None None None Never

  None (edit)
Description Jon Nettleton 2007-10-19 16:30:34 EDT
Bug to track upstream bug at freedesktop.org.  With the exa changes added to the
current rawhide xorg server this bug was also introduced.  Comment #6 in the
freedesktop bug has the relevant fix that needs to be added to exa_accel.c.

http://bugs.freedesktop.org/attachment.cgi?id=11757&action=view
Comment 1 Matěj Cepl 2007-10-22 13:01:59 EDT
Created attachment 234271 [details]
upstream patch
Comment 2 Bartosz Malasiewicz 2008-02-22 15:22:30 EST
It happens not only in gnome but also in kde. After enabling EXA, decorations
and styles are corrupted. Please fix this, because EXA gives much better
performance under intel driver. Without EXA it's almost impossible to watch HDTV
videos.  
Comment 3 Fedora Update System 2008-03-21 18:12:13 EDT
xorg-x11-server-1.3.0.0-44.fc8, xorg-x11-drv-amd-2.7.7.7-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.