Bug 34056 - XFree-4.0.3-3. Build problems on RedHat 7.0
Summary: XFree-4.0.3-3. Build problems on RedHat 7.0
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-30 12:59 UTC by Need Real Name
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-30 12:59:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-03-30 12:59:51 UTC
Hello!

I am trying to rebuild XFree-4.0.3-3 from the .src.rpm file (rpm --rebuild)
and I got the following error message:

install -c sis_dri.so /var/tmp/XFree86-4.0.3-root/usr/X11R6/lib/modules/dri
install in lib/GL/mesa/src/drv/sis done
make[5]: Leaving directory
`/usr/src/redhat/BUILD/XFree86-4.0.3/xc/lib/GL/mesa/src/drv/sis'
installing in lib/GL/mesa/src/drv/tdfx...
make[5]: Entering directory
`/usr/src/redhat/BUILD/XFree86-4.0.3/xc/lib/GL/mesa/src/drv/tdfx'
rm -f tdfx_dri.so~ tdfx_dri.so.map
gcc -o tdfx_dri.so~ -Wl,--version-script=tdfx_dri.so.map -shared 
../../../dri/dri_mesa.o 		../../../../dri/dri_tmm.o
../../../../dri/drm/xf86drm.o         	../../../../dri/drm/xf86drmHash.o 	
../../../../dri/drm/xf86drmRandom.o 		../../../../dri/drm/xf86drmSL.o
../../aatriangle.o 		../../accum.o 		../../alpha.o 		../../alphabuf.o 	
../../attrib.o 		../../bbox.o 		../../bitmap.o 		../../blend.o 	
../../buffers.o 		../../clip.o 	
	../../colortab.o 		../../config.o 		../../context.o         
../../copypix.o 		../../cva.o 		../../debug_xform.o 		../../depth.o 	
../../dlist.o 		../../drawpix.o 		../../enable.o 		../../enums.o 	
../../eval.o 		../../extensions.o 		../../feedback.o 		
../../fog.o 		../../get.o 		../../hash.o 		../../hint.o 		../../image.o 	
../../imaging.o 		../../light.o 		../../lines.o 		../../logic.o 	
../../masking.o 		../../matrix.o 		../../mem.o 		../../mmath.o 	
	../../pb.o 		../../pipeline.o 		../../pixel.o 	
	../../pixeltex.o 		../../points.o 		../../polygon.o 
        	../../quads.o 		../../rastpos.o 		../../re
adpix.o 		../../rect.o 		../../scissor.o 		
../../shade.o 		../../span.o 		../../stages.o 		../../st
ate.o 		../../stencil.o 		../../teximage.o 		
../../texobj.o 		../../texstate.o 		../../texture.o 	
        ../../texutil.o 		../../translate.o 		../../tr
iangle.o 		../../varray.o 		../../vb.o 		../../vb
cull.o 		../../vbfill.o 		../../vbindirect.o 		../../vb
render.o 		../../vbxform.o 		../../vector.o 		
../../vertices.o 		../../winpos.o 		../../xform.o 		
../../zoom.o 		../../X86/common_x86.o 		../../X86/common_x86_asm
.o 		../../X86/x86.o 		../../X86/x86_cliptest.o 	
        ../../X86/x86_vertex.o 		../../X86/x86_xform_masked2.o 		
../../X86/x86_xform_masked3.o 		../../X86/x86_xform_masked4.o 		
../../X86/x86_xform_raw2.o 		../../X86/x86_xform_raw3.o 		
../../X86/x86_xform_raw4.o ../../X86/mmx_blend.o ../../X86/3dnow.o 		
../../X86/3dnow_norm_raw.o 		../../X86/3dnow_vertex.o 		
../../X86/3dnow_xform_masked1.o 		../../X86/3dnow_xform_masked2.o 
        	../../X86/3dnow_xform_masked3.o 		../../X86/3dnow_
xform_masked4.o 		../../X86/3dnow_xform_raw1.o 		../../X8
6/3dnow_xform_raw2.o 		../../X86/3dnow_xform_raw3.o 		../../X8
6/3dnow_xform_raw4.o  tdfx_xmesa.o 		tdfx_init.o 		tdfx_ini
thw.o 		fxclip.o 		fxcva.o 		fxdd.o 		
fxddspan.o 		fxddtex.o 		fxfastpath.o 		fxglidew
.o 		fxpipeline.o 		fxrender.o 		fxsanity.o 	
        fxsetup.o 		fxtexman.o 		fxtrifuncs.o 		
fxvsetup.o  -lglide3 -lm -L../../../.. -lGL -lc
/usr/bin/ld: cannot find -lglide3
collect2: ld returned 1 exit status
make[5]: *** [tdfx_dri.so] Error 1
make[5]: Leaving directory
`/usr/src/redhat/BUILD/XFree86-4.0.3/xc/lib/GL/mesa/s
rc/drv/tdfx'
make[4]: *** [install] Error 2
make[4]: Leaving directory
`/usr/src/redhat/BUILD/XFree86-4.0.3/xc/lib/GL/mesa/s
rc/drv'
make[3]: *** [install] Error 2
make[3]: Leaving directory `/usr/src/redhat/BUILD/XFree86-4.0.3/xc/lib/GL'
make[2]: *** [install] Error 2
make[2]: Leaving directory `/usr/src/redhat/BUILD/XFree86-4.0.3/xc/lib'
make[1]: *** [install] Error 2
make[1]: Leaving directory `/usr/src/redhat/BUILD/XFree86-4.0.3/xc'
make: *** [install] Error 2
make: Leaving directory `/usr/src/redhat/BUILD/XFree86-4.0.3/xc'
error: Bad exit status from /var/tmp/rpm-tmp.8126 (%install)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.8126 (%install)



Thanks in advance for any help.


Daniel

Comment 1 Mike A. Harris 2001-03-31 06:47:28 UTC
Yep, that was a glitch that got by us because our build systems had
Glide installed already when Glide was folded into X, so we didn't notice
until someone without Glide installed tried to build X.  It should be
fixed now in XFree86-4.0.3-5 though.

ftp://people.redhat.com/mharris

Comment 2 Need Real Name 2001-04-02 06:27:26 UTC
Hi!

OK. I checked the URL you gave me and it is still 4.0.3-3 over there.

Daniel


Note You need to log in before you can comment on or make changes to this bug.