Bug 34060 - LPRng crashes with missing symbol
LPRng crashes with missing symbol
Status: CLOSED DUPLICATE of bug 33580
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-30 08:33 EST by Derek Viljoen
Modified: 2007-04-18 12:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-30 11:35:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Viljoen 2001-03-30 08:33:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-14 i686; Nav)


I updated my LPRng rpm using the up2date utility.  Now when I print I get
the following error:
 lpr: error while loading shared libraries: lpr: undefined
symbol: stat

Reproducible: Always
Steps to Reproduce:
1. lpr {filename}
2.
3.
	

Actual Results:  lpr: error while loading shared libraries: lpr: undefined
symbol: stat

Expected Results:  a printed page.

The rpm version up2date loaded is 3.6.24-2
Comment 1 Bob Houghton 2001-03-30 11:07:19 EST
I am glad someone else is having the same problem.  It lets me know that I don't
have to spend a whole lot more time trying to resolve it.

After an upgrade yesterday, I can no longer print.  I get the same error.  I
would try to find the error in source/Makefile, but I have a deadline from a
paying customer.  Let me know what you guys find.

Just in case it matters, this is what is different on my machine.  I am running
Kernel 2.2.18 with SMP (2 X 700 Mhz).

Comment 2 Bob Houghton 2001-03-30 11:07:36 EST
I am glad someone else is having the same problem.  It lets me know that I don't
have to spend a whole lot more time trying to resolve it.

After an upgrade yesterday, I can no longer print.  I get the same error.  I
would try to find the error in source/Makefile, but I have a deadline from a
paying customer.  Let me know what you guys find.

Just in case it matters, this is what is different on my machine.  I am running
Kernel 2.2.18 with SMP (2 X 700 Mhz).

Comment 3 Derek Viljoen 2001-03-30 11:35:50 EST
I was able to get past this by downloading the src rpm and rebuilding to my
shared libs.  This appears to be a glibc symbol change.  I went to a 7.0 system
that had not be upgraded, and ran strace on loading of the lpd and compared it
to the strace of my non-working system.  It craps out where the lpd is trying to
stat( /etc/lpd.conf ).  So I figured there must be a slight symbol change in the
glibc stuff.  I downloaded the srpm for LPRng and did a:
rpm --rebuild LPRng*.rpm
and then,
rpm -U --force LPRng*.rpm of the generated binary rpm.

Then everything works fine. (BTW, my glibc is 2.2-12)
Derek Viljoen
Comment 4 Jeremy Katz 2001-03-30 13:29:21 EST

*** This bug has been marked as a duplicate of 33580 ***

Note You need to log in before you can comment on or make changes to this bug.