Bug 34072 - Linuxconf creates incomplete ifcfg-eth0 file when using dhcp
Summary: Linuxconf creates incomplete ifcfg-eth0 file when using dhcp
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-30 15:36 UTC by Gareth Howell
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:47:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gareth Howell 2001-03-30 15:36:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.18 i686)


When using linuxconf to configure a single adapter machine that is set to
use dhcp, no DHCP_HOSTNAME setting is placed in ifcfg-eth0, thus preventing
pump or dhcpcd from using the '-h hostname' parameter.

Reproducible: Always
Steps to Reproduce:
1.use linuxconf to configure a hostname (and optionally an identical
adapter name)
2.accept changes and confirm that the adapter name has been cleared.
3.view the ifcfg-eth0 file and confirm that no DHCP_HOSTNAME is set
4. run ifup eth0 in debug mode and confirm that no parameters are provided
to pump
	

Actual Results:  The dhcp server does not have a client-hostname entry for
the problem machine, and thus dynamic dns updates cannot be used.

Expected Results:  The dhcpd.leases file entry should have had 
client-hostname entry.

dhcpd server is running on SUSE 6.4

Comment 1 Brent Fox 2002-06-05 16:11:31 UTC
Closing because we don't ship linuxconf anymore

Comment 2 Red Hat Bugzilla 2006-02-21 18:47:57 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.