Bug 341351 - multiarch conflicts in gpgme
multiarch conflicts in gpgme
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gpgme (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Šimon Lukašík
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 17:38 EDT by Bill Nottingham
Modified: 2014-03-16 23:09 EDT (History)
4 users (show)

See Also:
Fixed In Version: gpgme-1.3.0-6.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-01 12:55:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-10-19 17:38:42 EDT
gpgme (or one of its subpacakges) has multiarch conflicts when installed for both i386 and x86_64 in the Fedora development tree. For help in resolving them, see http://fedoraproject.org/wiki/PackagingDrafts/MultilibTricks. 

  file /usr/bin/gpgme-config from install of gpgme-devel-1.1.5-4.fc8 conflicts with file from package gpgme-devel-1.1.5-4.fc8

(Note that this is an automated bug filing.)
It would be nice to have these bugs fixed by the beta of Fedora 9.
Comment 1 Rex Dieter 2008-01-04 12:23:38 EST
%changelog
* Fri Jan 04 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 1.1.6-1
- gpgme-1.1.6
- multiarch conflicts in gpgme (#341351)
Comment 2 Michael Schwendt 2010-08-19 05:27:48 EDT
As I see it, this issue has been reintroduced in gpgme at some point of time. Both gpgme-config and gpgme.h conflict in gpgme-devel.i686 and gpgme-devel.x86_64
Comment 3 Tomas Mraz 2010-08-23 02:31:42 EDT
I am afraid that this conflict - at least in gpgme-config - is unresolvable. There is no way how to tell the gpgme-config which arch should be used for the CFLAGS and LDFLAGS output. And due to the now resolved bug 621698 the output is really different on the 32bit and 64bit architectures.
Comment 4 Bill Nottingham 2010-08-23 11:44:42 EDT
Could it be ported to pkg-config, with files in %{_libdir}/pkgconfig, and have gpgme-config just call that?
Comment 5 Tomas Mraz 2010-08-23 12:45:04 EDT
Except that wouldn't solve the problem that gpgme-config output for the 32 bit arch on the 64bit would be incorrect. But yes, it would solve the file conflict.
Comment 6 Rex Dieter 2010-08-23 13:04:06 EDT
or we could have gpgme-config.<arch> binaries and just call the right one with a wrapper if needed, one quick-n-dirty one:

exec gpgme-config.$(arch)


(but largely has the same problems as comment #5, though that case is not something handled very well in general on fedora anyway).
Comment 7 Bill Nottingham 2010-08-23 13:36:33 EDT
I would think either of the solutions from comment #5 or comment #6 could operate conditionally on uname output well enough that it should work as long as setarch is called.
Comment 8 Fedora Update System 2012-02-15 09:00:30 EST
gpgme-1.3.0-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gpgme-1.3.0-6.fc17
Comment 9 Fedora Update System 2012-02-15 20:55:50 EST
Package gpgme-1.3.0-6.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gpgme-1.3.0-6.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-1726/gpgme-1.3.0-6.fc17
then log in and leave karma (feedback).
Comment 10 Michael Schwendt 2012-02-17 17:17:07 EST
Further fixes are needed, so this is _the_ chance to include them:

  https://fedoraproject.org/wiki/Packaging:Guidelines#Requiring_Base_Package

On x86_64:

$ yum install gpgme-devel.i686
[...]
================================================================================
 Package                Arch       Version            Repository           Size
================================================================================
Installing:
 gpgme-devel            i686       1.3.0-6.fc17       updates-testing     111 k
Installing for dependencies:
 glibc                  i686       2.15-11.fc17       fedora              4.1 M
 gpgme                  i686       1.3.0-6.fc17       updates-testing     147 k
 libassuan              i686       2.0.1-2.fc17       fedora               59 k
 libgpg-error           i686       1.10-2.fc17        fedora               75 k
 libgpg-error-devel     x86_64     1.10-2.fc17        fedora               15 k
 nss-softokn-freebl     i686       3.13.1-20.fc17     fedora              123 k
 pth                    i686       2.0.7-15.fc17      fedora               86 k

# rpm -e libgpg-error-devel.x86_64
error: Failed dependencies:
	libgpg-error-devel is needed by (installed) gpgme-devel-1.3.0-6.fc17.i686
# rpm -qR gpgme-devel.i686
/bin/sh  
/bin/sh  
/bin/sh  
/sbin/install-info  
/sbin/install-info  
gpgme = 1.3.0-6.fc17
libgpg-error-devel  
libgpgme-pth.so.11  
libgpgme-pthread.so.11  
libgpgme.so.11  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
Comment 11 Fedora Update System 2012-04-23 23:18:09 EDT
Package gpgme-1.3.0-8.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gpgme-1.3.0-8.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-1726/gpgme-1.3.0-8.fc17
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-06-01 12:55:03 EDT
gpgme-1.3.0-8.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.