Bug 34149 - lpd, checkpc, lpr, lpq all fail with dynamic library problem
Summary: lpd, checkpc, lpr, lpq all fail with dynamic library problem
Status: CLOSED DUPLICATE of bug 33580
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: LPRng   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-30 20:19 UTC by Need Real Name
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-30 20:19:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-03-30 20:19:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-14 i686)


March 30 2001, lpd does not start anymore, lpq, lpr and lpstat fail too.

Reproducible: Always
Steps to Reproduce:
1.Boot
2.Look at the start messages
3.lpd fails to start
	

Actual Results:  [root@jolly /root]# /etc/init.d/lpd start  
Starting lpd: /usr/sbin/checkpc: error while loading shared libraries:
/usr/sbin/checkpc: undefined symbol: stat
/usr/sbin/lpd: error while loading shared libraries: /usr/sbin/lpd:
undefined symbol: stat
                                                           [FAILED]
[root@jolly /root]# checkpc
checkpc: error while loading shared libraries: checkpc: undefined symbol:
stat


Expected Results:  OK

It all worked yesterday (March 29th 2001).

Have I myself removed something from the system? Don't think so because
then I should get a message about missing libraries or files.

Have I messed up any config files? Possible, but probably not this time.

Have I run up2date? Yes. What did I update? Can't remember, sorry.  Where
to check? /var/log?? or ? Didn't find any information.

Anything else? Don't know.

I put this on low prio, I have other computers I can do the printing with
(non-linux).

Comment 1 Jeremy Katz 2001-03-30 20:36:56 UTC

*** This bug has been marked as a duplicate of 33580 ***


Note You need to log in before you can comment on or make changes to this bug.