Bug 341491 - multiarch conflicts in hdf
multiarch conflicts in hdf
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hdf (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 17:40 EDT by Bill Nottingham
Modified: 2014-03-16 23:09 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.2r2-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-05 17:18:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-10-19 17:40:05 EDT
hdf (or one of its subpacakges) has multiarch conflicts when installed for both i386 and x86_64 in the Fedora development tree. For help in resolving them, see http://fedoraproject.org/wiki/PackagingDrafts/MultilibTricks. 

  file /usr/include/hdf/h4config.h from install of hdf-devel-4.2r2-2.fc8 conflicts with file from package hdf-devel-4.2r2-2.fc8

(Note that this is an automated bug filing.)
It would be nice to have these bugs fixed by the beta of Fedora 9.
Comment 1 Patrice Dumas 2007-10-20 18:50:26 EDT
I have checked that one, and the difference is
(logically)

-#define H4_SIZEOF_INTP 4
+#define H4_SIZEOF_INTP 8

Fortunately, it is not used in the API. As far as a grep can
show the only symbols from h4config.h used are H4_HAVE_NETCDF 
and H4_F77_FUNC.

In my opinion we should modify h4config.h to avoid having this
symbol defined. I my opinion, there are 2 possibilities
* keep only the defines corresponding with H4_HAVE_NETCDF and
  H4_F77_FUNC.

or
* remove the H4_SIZEOF_INTP define. What do you prefer?
Comment 2 Bill Nottingham 2007-10-22 15:48:08 EDT
If that specific define isn't actually used anywhere, I'd just remove that line.
Comment 3 Orion Poplawski 2007-12-05 17:18:35 EST
Looks like you fixed this but didn't close the bug.
Comment 4 Patrice Dumas 2007-12-05 17:41:45 EST
I don't have a way to verify that I fixed it. I am waiting for 
the automatic mailing of multiarch conflicts.

Note You need to log in before you can comment on or make changes to this bug.