Bug 342 - tcpdump doesn't work with recent 2.1 kernels
tcpdump doesn't work with recent 2.1 kernels
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: tcpdump (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-08 02:53 EST by Marc MERLIN
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-09 12:22:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc MERLIN 1998-12-08 02:53:40 EST
moremagic:~# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:40:05:26:A8:69
          inet addr:192.168.204.1  Bcast:192.168.204.255
Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:261371 errors:0 dropped:0 overruns:0
frame:0
          TX packets:491259 errors:0 dropped:0 overruns:0
carrier:0
          collisions:0
          Interrupt:10 Base address:0x340

moremagic:~# LC_ALL=C tcpdump -i eth0
tcpdump: socket: Socket type not supported
moremagic:~# uname -a
Linux moremagic.magic.metawire.com 2.1.131 #20 jeu dic 3
22:20:18 PST 1998 i586 unknown

I can't say if how recently it's been broken. As far as I
can remember, I never got it to work with a 2.1.x kernel
(x>104)
Comment 1 Aleksey Nogin 1998-12-08 19:50:59 EST
You need to enable packet protocol in the kernel.

From the Configure.help:

CONFIG_PACKET
  The Packet protocol is used by applications which communicate
  directly with network devices without an intermediate network
  protocol implemented in the kernel, e.g. tcpdump. If you want them
  to work, choose Y. This driver is also available as a module called
  af_packet.o ( = code which can be inserted in and removed from the
  running kernel whenever you want). If you want to compile it as a
  module, say M here and read Documentation/modules.txt. If unsure,
  say Y.
Comment 2 Marc MERLIN 1998-12-09 01:25:59 EST
Thanks for the pointer. I had compiled this in, but as a module and
when I checked again after your answer I realized that modprobe
couldn't load the module automatically.
What's a bit annoying is that "can't locate module net-pf-17" is only
logged at the info level (it used to be at least warning), and thus
didn't make it to my console :-(
Adding "alias net-pf-17 af_packet" to /etc/conf.module solved
the problem. Maybe it'd be a nice idea to have a default file with
a few default entries.

Anyway the problem was mine, sorry for this bogus report and for
wasting your time. You can close this ticket
Comment 3 Jeff Johnson 1998-12-09 12:22:59 EST
Closed.

Note You need to log in before you can comment on or make changes to this bug.