Bug 34208 - choosing tcsh for user's shell prevents X from loading (gnome)
choosing tcsh for user's shell prevents X from loading (gnome)
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: tcsh (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-31 00:04 EST by ricdude
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-31 00:04:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ricdude 2001-03-31 00:04:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.9 i586)


If I set my user shell to /bin/tcsh, I can't login to X/gnome via gdm.  I
haven't tried alternate login managers, or KDE.

Reproducible: Always
Steps to Reproduce:
1. chsh user
2. select /bin/tcsh
3. try to log in to X/gnome via gdm


Actual Results:  X exits, and returns to the login screen

Expected Results:  my gnome desktop should have loaded.

if I change the user shell to /bin/bash, all is well.
Comment 1 Eido Inoue 2001-06-28 11:02:57 EDT
tried the steps you mentioned. With gdm/gnome, I login, change from bash to tcsh
via chsh, logout and log back in-- successfully via graphic login and text mode
login.
Comment 2 Len Moss 2001-06-29 02:10:52 EDT
This might be related to the change in tcsh behavior introduced in RH 7 in
response to bug 19926.  At our site, it caused a user's .login script that
happened to contain minor error to be sourced during the startup of the X
session.  The startup failed because of this error with the symptoms you
described.

Note You need to log in before you can comment on or make changes to this bug.