Bug 34230 - Apache rendomly dies
Summary: Apache rendomly dies
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: apache   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-31 18:26 UTC by Need Real Name
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-04 18:00:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-03-31 18:26:50 UTC
The apache-1.3.19-2 occasionally dies.
This is a message in error_log:

[Sat Mar 31 07:00:43 2001] [error] (32)Broken pipe: accept: (client socket)

And this is it. Server died after this.

Vladislav

Comment 1 Need Real Name 2001-04-02 15:20:51 UTC
This problem seems to be related to 
restarting the server.
First, multiple HUP signals from /etc/logrotate.d/apache
may easily kill the server.
(when next -HUP is delivered when first -HUP is is still processing)

Second from time to time a SINGLE HUP signal kills the apache.
This is a command which sometime JUST KILLS apache 
when executed manually.

kill -HUP `cat /var/run/httpd.pid`



Comment 2 Need Real Name 2001-04-04 18:00:20 UTC
Another thing I would recommend to change in 
/etc/logrotate.d/apache
is to replace multiple entries 
by a single one
like
/var/log/httpd/access_log /var/log/httpd/error_log /var/log/httpd/agent_log
/var/log/httpd/referer_log {
   missingok
   sharedscripts
   postrotate
        /bin/kill -HUP `cat /var/run/httpd.pid 2>/dev/null` 2> /dev/null ||
true    endscript
   endscript
}

This will prevent killing apache by delivering multiple -HUP signals

Comment 3 Nalin Dahyabhai 2001-04-04 22:31:43 UTC
Thanks!  This'll be integrated into apache-1.3.19-6 and later.


Note You need to log in before you can comment on or make changes to this bug.