Bug 342321 - multiarch conflicts in libpng
multiarch conflicts in libpng
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libpng (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 17:48 EDT by Bill Nottingham
Modified: 2014-03-16 23:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-30 17:54:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-10-19 17:48:15 EDT
libpng (or one of its subpacakges) has multiarch conflicts when installed for both i386 and x86_64 in the Fedora development tree. For help in resolving them, see http://fedoraproject.org/wiki/PackagingDrafts/MultilibTricks. 

  file /usr/bin/libpng12-config from install of libpng-devel-1.2.16-3.fc8 conflicts with file from package libpng-devel-1.2.16-3.fc8

(Note that this is an automated bug filing.)
It would be nice to have these bugs fixed by the beta of Fedora 9.
Comment 1 Tom Lane 2007-10-20 00:25:17 EDT
[ squint ... ]  So how, exactly, can a package conflict with itself?

If there's a real problem here, you need to provide much more detail.
Comment 2 Bill Nottingham 2007-10-22 16:08:39 EDT
The issue is when both the i386 and x86_64 packages are installed. Generally,
the fix is to use pkg-config. How do the libpng12-config scripts differ between
arches?
Comment 3 Tom Lane 2007-10-22 21:55:33 EDT
Ah, got it.  Your automated script would be more helpful if it included the arch when identifying the 
conflicting packages...
Comment 4 Bill Nottingham 2007-10-23 13:16:42 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=349091 filed.
Comment 5 Tom Lane 2007-10-30 17:54:11 EDT
Hmm, it seems that this is already fixed in libpng 1.2.22 --- looks like upstream adopted pkg-config.

Note You need to log in before you can comment on or make changes to this bug.