Bug 34273 - Xemacs should work with nomule or -unibyte mode too.
Xemacs should work with nomule or -unibyte mode too.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: xemacs (Show other bugs)
7.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-01 04:56 EDT by Krzysio (Chris) Leszczynski
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-03 12:39:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krzysio (Chris) Leszczynski 2001-04-01 04:56:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-14 i686)


Xemacs refuses to run -unibyte, i.e. without MULE. Also eval'ing
(standard-display-european) doesn't switch mule. MULE has broken
upper/lower case folding and should be disabled for European languages.

Reproducible: Always
Steps to Reproduce:
[these are actually 3 different effects, the don't have to be made
step-by-step.]
1. Run: xemacs -unibyte # It still has MULE it menu-bar,
2. While in xemacs. Eval (standard-display-european), the mule is still
there.
3. Enter quail mode and try to enter accented character, make it into
region and try C-x C-u or C-x C-l, nothing happens to accented although it
correctly changes latin characters.

Expected Results:  In GNU emacs, or in previous releases of xemacs from
Redhat step 1 or step 2 runs emacs without MULE.
Also GNU emacs correctly changes the case of any character


Actually the MULE in Xemacs is broken and I don't think Redhat can make
anything with this case except waiting till Xemacs group fixes it. This bug
is even documented.
Try looking at information on function set-case-table, there's a remark:
  BUG: Under XEmacs/Mule, translations to or from non-ASCII characters
    (this includes chars in the range 128 - 255) are ignored by
    the string/buffer-searching routines.  Thus, `case-fold-search'
    will not correctly conflate a-umlaut and A-umlaut even if the
    case tables call for this.

I think a non-mule version should be also provided, because otherwise I
can't edit ISO-8859-2 files (I'm Polish). Thanks to .src.rpm I can easily
produce an xemacs version just by setting --with-mule=no in configure part.
Comment 1 Trond Eivind Glomsrxd 2001-04-02 12:05:52 EDT
"-unibyte" is not a documented startup option (at least, I can't find it with
--help or in the man page), so I'm not terribly surprised it doesn't work.
"NOTABUG".

As for problems with case, I suggest you report it with M-x report-emacs-bug -
this issue isn't listed in PROBLEMS. "WONTFIX" - this is better left to the
xemacs maintainers.
Comment 2 Krzysio (Chris) Leszczynski 2001-04-03 12:34:42 EDT
I don't agree that I should report it via emacs-bug. Xemacs maintainers are
already aware of this bug and they're working on it. It is documented. Try
(describe-function 'set-case-table). Meanwhile the MULE works incorrectly for
european languages with diacritics, i.e. for virtually every non-english latin
based language.
Comment 3 Krzysio (Chris) Leszczynski 2001-04-03 12:39:15 EDT
Sorry, I forgot to reopen the bug, I left it as WONTFIX. See my previous
comment.
Comment 4 Trond Eivind Glomsrxd 2001-04-12 18:49:19 EDT
WONTFIX, as the mule issues is an architectural issue. FTR, in works in Emacs.

Note You need to log in before you can comment on or make changes to this bug.